Itoo Software Forum

Author Topic: cannot seem to get the tint function to work  (Read 2194 times)

simmsimaging

  • Full Member
  • ***
  • Posts: 113
cannot seem to get the tint function to work
« on: February 06, 2012, 06:19:41 AM »
I've been trying with the material rollout, and the actual Forest Material, but I can't seem to get the colour tinting to work at all. I ended up making a simple dummy file and can't get it happening there either.

Can you look at the file and tell me what I'm doing wrong? The goals is to get the same tex that is on the plane to colourize the FPP instances.

http://www.simmsimaging.com/upload/files/2012.02.05_2118_fpp_colour_test.zip/211857_fpp_colour_test.zip.zip (78.84 KB)


Thanks!
/b

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3156
    • iToo Software
Re: cannot seem to get the tint function to work
« Reply #1 on: February 06, 2012, 09:20:37 AM »

Please, set the Surface in mode XY. It seems the UV mode is not using the coordinates properly, we will check it.

Carlos Quintero
iToo Software

simmsimaging

  • Full Member
  • ***
  • Posts: 113
Re: cannot seem to get the tint function to work
« Reply #2 on: February 07, 2012, 07:09:26 PM »
Is it possible to add the option to have the colour tinting in the Material rollout be done *with* the Forest shader one? Right now the Forest shader overrides the FPP object level, but I would love to be able to have both.

Example:  my grass is made of individual blades and each is tinted randomly using the Forest Shader so I get a nice variation per blade, but now I want to add an overall tint to vary up the pattern of the whole field, so if I could add a map at the object level and have it add to the shader level I would be golden.

Possible?

/b

GF1991

  • Newbie
  • *
  • Posts: 33
Re: cannot seem to get the tint function to work
« Reply #3 on: February 08, 2012, 07:07:16 AM »
i tried to run your scene Brett but when i press render i get like thousands of "invalid geometric normal" warnings in the vray LOG window....

simmsimaging

  • Full Member
  • ***
  • Posts: 113
Re: cannot seem to get the tint function to work
« Reply #4 on: February 08, 2012, 07:23:32 AM »
renders fine here - might be a Vray version issue as I run a 2.0 beta.

/b

GF1991

  • Newbie
  • *
  • Posts: 33
Re: cannot seem to get the tint function to work
« Reply #5 on: February 08, 2012, 08:44:01 AM »
mine is 2.20.03...should not be that much of a difference

GF1991

  • Newbie
  • *
  • Posts: 33
Re: cannot seem to get the tint function to work
« Reply #6 on: February 08, 2012, 08:52:07 AM »
right....i had to click on the forrest object to solve the issue...........strange
it appeared pitch black at first...once i clicked on it it was fine


iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3156
    • iToo Software
Re: cannot seem to get the tint function to work
« Reply #7 on: February 08, 2012, 09:18:52 AM »
Is it possible to add the option to have the colour tinting in the Material rollout be done *with* the Forest shader one? Right now the Forest shader overrides the FPP object level, but I would love to be able to have both.

We prefer to not modify the tinting code, because it is pretty complex now.

Anyways, it is not necessary: you can combine multiple "Forest Color" using a "Composite" map, some of them working as texture and other tinting the elements. The combination is very flexible, since you can adjust the weight, mixing mode, etc.

Carlos Quintero
iToo Software

simmsimaging

  • Full Member
  • ***
  • Posts: 113
Re: cannot seem to get the tint function to work
« Reply #8 on: February 08, 2012, 10:05:34 AM »
Ah - good idea! I use the Composite map all the time but it didn't occur to me!

Thanks!
/b