Itoo Software Forum

Author Topic: Corona interactive mode with Itoo Forest cause 3ds Max to freeze.  (Read 853 times)

KarloBalboa

  • Newbie
  • *
  • Posts: 2
Hi everyone,
 I have an issue with the interactive mode of Corona Renderer with Itoo Forest Pack. When I'm working with heavy scenes and I try to pan view in interactive mode and in isolate view, 3ds Max freezes for couple of minutes. I investigated it, and found out that Corona interactive mode with Itoo Forest Pack cause the freezing of 3ds max. It's happening only when I try to pan view in isolate view. It seems that corona is trying to load all of Itoo Forest Pack instances even if I isolate just one independent object from all scene. I created simple scene to check if others will experience the same problem. I'm sure it's not my computer problem, because I tried this in two different computers, results are equal. But I'm not sure if this is Corona or ItooSoft fault. I have latest Itoo Forest Pack plugin and 2017 3ds Max.
Could anyone please check on this simple scene if any of you experience this behavior too?


iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3315
    • iToo Software
Re: Corona interactive mode with Itoo Forest cause 3ds Max to freeze.
« Reply #1 on: May 03, 2017, 05:17:41 PM »
Please, be sure you have Max 2017 updated to the latest update.
This problem has been reported in other Max versions, and was caused by a bug which is fixed in recent service packs:

https://knowledge.autodesk.com/sites/default/files/file_downloads/3dsMax2017_SP2_Readme.htm

MAXX-30316    Slow node creation / modifier application in complex scene

We cannot reproduce the problem here (Max 2017 SP3 + Hotfix 1).
There is a delay of of 5-8 sec. with some events (not 2 min.), because the Forest object must be rebuilt. That's normal because there are 2.7 mill. of scattered items:



Please note that using Interactive Render, Forest is computing the number total of items for render, not for viewport. So the performance hit may be significative.
But the 2 min. delay probably is caused by the bug described above.

« Last Edit: May 03, 2017, 05:19:39 PM by iToo »
Carlos Quintero
iToo Software