Itoo Software Forum

Author Topic: Custom Edit mode - trees changed itno an expoled loaction  (Read 2870 times)

HL4669

  • Guest
Custom Edit mode - trees changed itno an expoled loaction
« on: November 02, 2009, 03:47:38 PM »
I have created a number of trees in specific locations using the custon edit feature in forrest pack pro 3.2.4. when re-opening the saved file it appears corrupt and the trees are all aligned in diagonal lines in random locations. Is anyone aware of what is wrong?

thanks

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3319
    • iToo Software
Re: Custom Edit mode - trees changed itno an expoled loaction
« Reply #1 on: November 02, 2009, 08:32:39 PM »

Well, it taked a while but we just found the problem: when Forest places the trees over the surface, it must modify only the Z value. But if the surface has a rotation applied, the items are wrongly displaced in X/Y as well (because a bug).

The real issue comes in "Custom Edit" mode, because this displacement is added incrementally and the trees loose their original position. Unfortunately, once the trees are displaced there is not way to restore the position. You must to move them manually... sorry about that. :(

How to fix it:

- Apply a "Reset Transform" (Utility Panel) to the surface before using it.

In the latest beta versions this issue is partially fixed, because in "Custom Edit" mode the position of the trees can be restored clearing the surface. However, we must fix yet the alignment error for rotated surfaces (it must be solved for the next patch).

Sorry for the inconveniences, but using the Reset Transform trick must avoid this problem for your next projects.

Carlos Quintero
iToo Software