Itoo Software Forum

Author Topic: Custom library, billboard object shadows incorrect  (Read 1152 times)

SG9418

  • Newbie
  • *
  • Posts: 5
Custom library, billboard object shadows incorrect
« on: January 30, 2013, 12:58:33 PM »
I'm currently looking at creating some of my own material libraries and have set up a 2D material. But when I use a daylight system, 2 planes, every tree over itself the, I get a flattened colour image of the 2D tree inside it's shadow

Am I doing something wrong?

I have noticed that if I uncheck the 'Hide planes on viewport' option I can see the flattened plane that is rendered in mental ray in the viewport. I can also see it on the classic trees supplied with forest pack, it doesn't render though on the billboards supplied with forest pack.

It does render on my custom objects though
« Last Edit: January 30, 2013, 01:14:34 PM by SG9418 »

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3158
    • iToo Software
Re: Custom library, billboard object shadows incorrect
« Reply #1 on: January 30, 2013, 01:20:47 PM »

Usually, the best choice for billboards is 1 Plane. Using the facing camera option, should not be problems using this geometry.

Also be sure you use Forest Material for them. This material is required to cast the fake shadows, and for removing the self-shadow artifacts.

You can find some tips for using billboards here: http://www.itoosoft.com/forum/index.php?topic=448.0

Carlos Quintero
iToo Software

SG9418

  • Newbie
  • *
  • Posts: 5
Re: Custom library, billboard object shadows incorrect
« Reply #2 on: January 30, 2013, 06:02:55 PM »
Brill!! This works perfectly now. Thanks for your help