Itoo Software Forum

Author Topic: default grass presets too blueish green - how do I change this  (Read 2371 times)

Nosdrovni

  • Newbie
  • *
  • Posts: 3
Hello,

we're using max 2009 design with FP 4.0.3

we love (!) the new Grass Presets (Forest Library > Presets > Grass) since it finally allows us to use really large patches of grass and still have 1) a good closeup 2) good rendering speed. Thank you for this wonderful new presets, I tried for days (in previous versions of FP) and couldn't achieve this effect, even after reading many tutorials and tips.

But..

the grass looks too blueish for us. We want young, bright green grass! I've tried to change it using

1. forest color (no effect)
2. changing fp_grasstexture_difusse_blue (which it seems to use extensively) with photoshop (small effect)
3. trying to put a color map (RGB) on all the textures used (a lot of work) which lowers the blue chanel (small effect)

but there must be a better way to render a nice bright green grass with these presets.

does anyone know where we should change the color of the grass presets or why it is rendering blueish?

thanks,
« Last Edit: April 18, 2013, 10:16:47 AM by Nosdrovni »

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3151
    • iToo Software
Re: default grass presets too blueish green - how do I change this
« Reply #1 on: April 18, 2013, 11:29:48 AM »
We're glad you like the new presets ! We will create more of them for next updates.

About the materials, i'm afraid there is no way to get colors suitable for all scenes. Most of times we will necessary to adjust it. In this case, i suggest the following procedure (for VRay, but the method is similar for other engines):

- Use the same material for front/back in VRay2SideMtl, turning the Back material tick. This will disable the fp_grasstexture_difusse_blue texture.
- In Forest Color set Tint->Override->Random Strength to 100%-100%
- Set both tint color selectors to pure green.

With this configuration, you will get a brillant greenish color. From here, adjust Strength/Tint to get the tone you like. I hope that helps.

Carlos Quintero
iToo Software

Nosdrovni

  • Newbie
  • *
  • Posts: 3
Re: default grass presets too blueish green - how do I change this
« Reply #2 on: April 18, 2013, 12:53:21 PM »
Hello,

thank you for the quick reply. This worked for me. Maybe this will help other people as well so this is what I did:

- tick the material with the 'pick material from object'
- you'll see something like forest_automaterial_1 (or 2, 3..)
- click _fp_grass_a (*)
- disable the back material (**)
- click the front material
- diffuse slot
- and use the tint settings (I used 71/255/64 > 71/255/192; 0 > 70%)

2 remarks:

* why is this? There are so many sub materials and I only had to change _fp_grass_a?
** I reenabled the back material and changed the diffuse image to C:\Program Files (x86)\Itoo Software\Forest Pack Pro\maps\Presets\fp_grasstexture_difusse2.jpg (could be different on your pc). This made the grass look even better, probably because it now has a texture on the back?

anyway, thanks for the support!

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3151
    • iToo Software
Re: default grass presets too blueish green - how do I change this
« Reply #3 on: April 18, 2013, 01:05:59 PM »

Quote
* why is this? There are so many sub materials and I only had to change _fp_grass_a?

We use the same multi-sub for several presets. In this case, only is used one of the grass materials.

Quote
** I reenabled the back material and changed the diffuse image to C:\Program Files (x86)\Itoo Software\Forest Pack Pro\maps\Presets\fp_grasstexture_difusse2.jpg (could be different on your pc). This made the grass look even better, probably because it now has a texture on the back?

Yes, probably this enhances the translucency effect. Inially i suggested turning it off, to make the material simpler, hence easier to see the color changes.

Carlos Quintero
iToo Software

Nosdrovni

  • Newbie
  • *
  • Posts: 3
Re: default grass presets too blueish green - how do I change this
« Reply #4 on: April 18, 2013, 01:07:29 PM »
that makes sense! thank you!