Itoo Software Forum

Author Topic: Distribution Mode Path Changed in 7.4.1 from 7.3  (Read 172 times)

supergraphiq limited

  • Newbie
  • *
  • Posts: 3
Distribution Mode Path Changed in 7.4.1 from 7.3
« on: June 12, 2022, 03:04:27 AM »
I've opened files since I've updated my forest pack to the latest and the object are no longer following along with spline the way they were in previous versions. See below in my viewport and a previous rendering of the objects where they were following the spline correctly. Any configuration turned off or on "follow x and z" doesn't fix the problem.

I haven't changed anything I've just opened the file with the new version. I haven't been checking my files so I'm hoping this is just a one-off, but I did send the image to a client to get printed on a billboard so I really need to know why this is happening so I can fix it and also make sure it's not affecting other images.


Thanks,

Yusef


Paul Roberts

  • iToo Software
  • Hero Member
  • *****
  • Posts: 2547
Re: Distribution Mode Path Changed in 7.4.1 from 7.3
« Reply #1 on: June 13, 2022, 04:45:44 PM »
Hi Yusef,

Sorry to hear you are facing these issues. I'm looking through the release notes and I can't see anything obvious that would affect orientation on paths. Would you be able to send a simplified version of the file - maybe just the FP object. houses, surface and spline - to helpdesk@itoosoft.com so we can take a closer look?

Many thanks,

Paul
Paul Roberts
iToo Software

supergraphiq limited

  • Newbie
  • *
  • Posts: 3
Re: Distribution Mode Path Changed in 7.4.1 from 7.3
« Reply #2 on: June 15, 2022, 09:10:36 PM »
I've been able o resolve the issue, but it took some doing. I'm not sure where the change might have occurred. ( I updated my corona version along with forestpack and railclone to all the latest versions) The proxy house that I was using had the base transforms flipped in a weird way, which may have been like that from the beginning, but possibly corona proxy and/or forestpack changed how it was interpreting the transform in laying it out across the spline.

Even when I turned the objects back into meshes and tried to reset the transform it kept flipping back. I had to create a box, attach the mesh to it and then delete the box for it to maintain the right transform. I'm not sure why or how this was happening, but maybe the object was corrupt.


supergraphiq limited

  • Newbie
  • *
  • Posts: 3
Re: Distribution Mode Path Changed in 7.4.1 from 7.3
« Reply #3 on: June 16, 2022, 02:15:33 PM »
I've actually found new forest objects that I've created in the past on different objects now that aren't working the way they previously worked. I will send just the forest objects and references to the above email.

Thanks,

Y