Itoo Software Forum

Author Topic: Diversity Map Problem  (Read 1036 times)

Chipstarrr

  • Newbie
  • *
  • Posts: 4
Diversity Map Problem
« on: June 03, 2014, 04:34:26 PM »
Hello,

I am trying to use a jpg as a diversity map. I have created the map in photoshop with 4 areas eacch a different colour...BLUE...RED...GREEN...YELLOW...on a black background. I have added 4 plants to my Forest Pro scene and given each one the matching RGB values for the area I wish it to show up over my map.

The problem occurs when the areas that I need to have no grass, the black areas are randomly loading plants from one of the other colours. So lets say RED, GREEN and BLUE are loaded correctly but YELLOW is on the YELLOW areas and the black. I have swapped the colours around and still this happens!

Any ideas on how to fix?

Oh and I read in the help files the Threshold option should fix this but it does not!

Cheers

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3319
    • iToo Software
Re: Diversity Map Problem
« Reply #1 on: June 03, 2014, 07:44:57 PM »
The Diversity map defines the type of plant according to the color IDs, but not if there should be a plant or a gap (this is done by the Distribution map). So, black pixels may generate wrong results, because have not a well defined color component.

Try assigning the same texture both as Diversity and Distribution map, and adjust the Threshold value (i.e. to 0%). That should generate the result you want.
Carlos Quintero
iToo Software

Chipstarrr

  • Newbie
  • *
  • Posts: 4
Re: Diversity Map Problem
« Reply #2 on: June 06, 2014, 12:15:09 PM »
Thanks that worked perfectly.

Another quick question. I am using Forest Pack with 3ds Max and Octane render. I know that octane does not support Forest Colour so to create diversity in colours of a scene of bushes I have tried to apply different materials to 2 types of bush in the Forest Modifier. The problem is once I have created my 2 textures and applied them to the separate bushes only one of the textures is used for both. I have tried un-ticking "Consolidate materials" and also "Optimise materials" with no luck. Actually this error seems sporadic as "optimise materials" did work once, it made each bush use a separate material, but when I went back into the material to change some values it would not update again! This is getting pretty frustrating as I need to somehow have a diverse range of textures and Forest just seems to want to use the same texture for all instances of a specif plant!

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3319
    • iToo Software
Re: Diversity Map Problem
« Reply #3 on: June 06, 2014, 01:04:23 PM »
That is a defect of the Octane implementation: it always gets the material from the Custom Object, ignoring the material defined in the Geometry List.
As workaround, create several custom objects, each one with its own material.

Unfortunately we cannot fix this issue, since the code was written by the Otoy developers, and is part of the Octane core.
Carlos Quintero
iToo Software

Chipstarrr

  • Newbie
  • *
  • Posts: 4
Re: Diversity Map Problem
« Reply #4 on: June 06, 2014, 02:40:38 PM »
OK that worked perfectly!

Thanks again :-)