Itoo Software Forum

Author Topic: Error reading forest.cfg file!  (Read 6629 times)

UF7753

  • Newbie
  • *
  • Posts: 24
Error reading forest.cfg file!
« on: April 08, 2008, 05:01:47 PM »
i'm getting an error when i try to use forestpro. it was working 2 days ago, but today when i tried to use it i got this error:
"Error reading forest.cfg file!
Please, reinstall Forest or contact with Itoo Software."

i did try to reinstall, but i get the same error. i'm using max9 on winxp. i can provide more info if someone has need of it.
thanks in advance.

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3319
    • iToo Software
Re: Error reading forest.cfg file!
« Reply #1 on: April 08, 2008, 05:23:24 PM »
Hi,

Please, try a manual installation following our FAQ:

http://www.itoosoft.com/english/menu.php?id=forest_faq#18

Forest install some files, including 'forest.cfg' in user local folders at 'Documents and Settings'. I think some permissions would have changed on this directory, and Forest cannot locate the configuration files.

Carlos Quintero
iToo Software

UF7753

  • Newbie
  • *
  • Posts: 24
Re: Error reading forest.cfg file!
« Reply #2 on: April 08, 2008, 06:29:54 PM »
thanks for the reply. i did try the manual install and i get the same error.
i got this error today before i tried to reinstall and it was working 2 days ago. i did not do anything unusual with the pc in the last 2 days - that i can remember.

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3319
    • iToo Software
Re: Error reading forest.cfg file!
« Reply #3 on: April 08, 2008, 07:29:55 PM »

Please, run this program and tell me the results:

http://www.itoosoft.com/files/CheckForestInstall11.exe

Carlos Quintero
iToo Software

UF7753

  • Newbie
  • *
  • Posts: 24
Re: Error reading forest.cfg file!
« Reply #4 on: April 09, 2008, 10:42:26 AM »
i ran that exe file and i've attached the log. i did have problems with my account and a new profile was created. this was a couple of weeks ago. i thought i had copied everything from my old profile. the folder is still on my HD so i should be still able to copy files if i have missed something.
« Last Edit: April 13, 2008, 01:46:10 PM by UF7753 »

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3319
    • iToo Software
Re: Error reading forest.cfg file!
« Reply #5 on: April 09, 2008, 04:47:44 PM »
It's strange... all seems correct in the log, the plugcfg folder exists and the installer can copy files on it.

Can you see 'forest.cfg' at C:\Documents and Settings\colincreamer.PARKHOOD\Local Settings\Application Data\Autodesk\3dsmax\9 - 32bit\enu\plugcfg ?

If you are not using the local profiles of Max 9, i suggest you disable it: edit 'InstallSettings.ini' file from Max root folder, and set

useUserProfiles=0

With this parameter, Max doesn't use the local user folders, searching the 'plugcfg' directory at <maxdir>/plugcfg, as in previous Max versions.

Must be some problem with your local profile, but is difficult to find it without having access to the computer.

Carlos Quintero
iToo Software

UF7753

  • Newbie
  • *
  • Posts: 24
Re: Error reading forest.cfg file!
« Reply #6 on: April 12, 2008, 05:55:37 PM »
back again. sorry for being so slow, but you are right. it's something to do with my profiles. as i said i had problems connecting to the network a few weeks ago, but a new profile was created and off i went on that. when i log on to my old account the forest plugin works the finest. i'll look at the max settings and see if i cannot replicate the paths when i log on to my newer account. i'll post back if i get it sorted. i'm trying to push the idea of using itoosoftware to represent vegetation.

UF7753

  • Newbie
  • *
  • Posts: 24
Re: Error reading forest.cfg file!
« Reply #7 on: April 12, 2008, 06:28:13 PM »
Yes, i copied the enu folder in the local settings from my old profile to the new one. the plugin works again. i should've been paying heed to what i was doing for such a simple error to hold me up.

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3319
    • iToo Software
Re: Error reading forest.cfg file!
« Reply #8 on: April 12, 2008, 06:49:36 PM »

Ok. I'm glad you solved it.  ;)

Carlos Quintero
iToo Software