Itoo Software Forum

Author Topic: exclude objects  (Read 1257 times)

ES1947

  • Newbie
  • *
  • Posts: 21
exclude objects
« on: December 04, 2013, 10:19:40 PM »
hi

i'm working on a masterplan where I would like add some plants, but exclude the roads.

i select the ground then, under areas I add the road.

it work fine, except from the exclude area seems to be offset.

can this somehow be adjust? in both x and y?

otherwise, it's a very useful plugin!

thanks

ES1947

  • Newbie
  • *
  • Posts: 21
Re: exclude objects
« Reply #1 on: December 04, 2013, 10:32:39 PM »
it works very well, but there are some glitches :-/

I don't know what I do wrong :-/

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3152
    • iToo Software
Re: exclude objects
« Reply #2 on: December 05, 2013, 05:40:31 AM »
Do you use exclude by Object or Spline ?

The exclude by object is based in a bitmap mask which Forest builds internally. This mode is less precise than a spline, specially using large objects. I mean, it may work fine for a house, but worse for a large road. Although you can increase the resolution of the bitmap (see the area parameters), in this case i suggest to use an area spline. It's much faster and precise.

Besides that, try setting Area->Boundary Checking to Size. That may help.
Carlos Quintero
iToo Software

ES1947

  • Newbie
  • *
  • Posts: 21
Re: exclude objects
« Reply #3 on: December 05, 2013, 08:26:41 AM »
Hi Carlos

drwaing splines is sure not faster, but it seems necessary.

i have added both the road, and an extra spline to remove the issues. it seems that trees also enter inside the spline.

boundery checking is grayed out.

i have attached a screenshot. the spline is the thin red line. i have marked the issues with the blue line.

it is a very large model, can this cause the problems?

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3152
    • iToo Software
Re: exclude objects
« Reply #4 on: December 05, 2013, 08:49:50 AM »
Sorry, i mean that area spline works internally faster, but obviously it requires some extra work.

I forgot to mention it: Boundary Checking is enabled only for Include/Surface areas, but it affects to all Exclude areas.

The size of the model theorically should not be a problem. Please, be sure the tree's pivot is centered. If it doesn't work, send us a stripped scene to support@itoosoft.com.
Carlos Quintero
iToo Software

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3152
    • iToo Software
Re: exclude objects
« Reply #5 on: December 05, 2013, 10:19:50 AM »
Thanks for the scene. Problem was the Transform->Translation (20%). It's applied after computing the item's position, so may affect the area's boundary.
A lower value should fix the problem.
Carlos Quintero
iToo Software

ES1947

  • Newbie
  • *
  • Posts: 21
Re: exclude objects
« Reply #6 on: December 06, 2013, 09:30:34 AM »
Hi Carlos

 :-[ :-[ :-[
sorry my fault, I'm still learning, but i'm glad it was easy to fix :-)

once again thanks for your fast and efficient support!

thanks