Itoo Software Forum

Author Topic: Exclusion Problems  (Read 2713 times)

Mike Truly

  • Full Member
  • ***
  • Posts: 115
    • Truly Media
Exclusion Problems
« on: November 21, 2009, 03:25:54 PM »
I am having problems getting Exclusion Splines to work properly in FP 3.2.4.

I have a grass area defined by an Include spline and in the middle of this, I have a small Exclude spline (consisting of 5 sub-splines).  The exclude splines are vertex animated so that the exclude spline represents gouges in the grass.  As the exclude spline is animated, gouges are revealed (and grass should be removed in this area).  This has worked fine for me in the past but currently, some of the gouges have no grass removed and others have grass removed intermittantly rather than consistently.

This animation is network rendered, if that makes a difference.

Attached is a file showing the problem.  Render frame 985 and then frame 986.  Or do a net-render of frames 600-1000.  You will see grass popping on and off.   A few of the grass planes probably pop because of the animation of the spline barely touching their centers.  But there is a huge area within the animated spline where grass should be consistently removed but it is filled with grass.

Thanks for any ideas.
Sincerely,

Mike Truly
----------------------------------------------------------------
Truly Media
1.800.829.4990
http://www.trulymedia.com

Mike Truly

  • Full Member
  • ***
  • Posts: 115
    • Truly Media
Re: Exclusion Problems
« Reply #1 on: November 21, 2009, 03:32:45 PM »
Also... notice there are 5 gouge splines which are animated to be revealed.  During the animation, many of  these revealed splines result in NO grass removed... why is that?

Again, I have used this technique in the past and it has worked fine.

Thanks!
Sincerely,

Mike Truly
----------------------------------------------------------------
Truly Media
1.800.829.4990
http://www.trulymedia.com

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3156
    • iToo Software
Re: Exclusion Problems
« Reply #2 on: November 21, 2009, 05:37:53 PM »

This is a bug of 3.2.4 version. The exclude spline doesn't work if it's not aligned in Z with the include spline (including all vertexes).

This issue is fixed in latest beta releases.

Carlos Quintero
iToo Software

Mike Truly

  • Full Member
  • ***
  • Posts: 115
    • Truly Media
Re: Exclusion Problems
« Reply #3 on: November 21, 2009, 06:50:47 PM »
Thanks Carlos... I'll give the beta a try.

Sincerely,

Mike Truly
----------------------------------------------------------------
Truly Media
1.800.829.4990
http://www.trulymedia.com