Itoo Software Forum

Author Topic: Failure to Initialize  (Read 280 times)

BH1040

  • Newbie
  • *
  • Posts: 12
Failure to Initialize
« on: April 05, 2019, 01:34:16 AM »
Although I have used FPpro in the past on this same machine, I can't get FP to show up in the Create pull-down menu in 3dsmax 2016.
I have:
-downloaded and installed V6 and all the libraries.
-re-subscribed and input new license info.
-activated the license using license manager.
Installed directories appear correct.
C:/Program Files/Itoo Software/Forest Pack Pro
FPpro DLO shows up in the C:/Program Files/Autodesk/3ds Max 2016/Plugins directory.
Nothing I do seems to initialize FPpro when I start 3dsmax.

Michal Karmazín

  • iToo Software
  • Hero Member
  • *****
  • Posts: 1661
Re: Failure to Initialize
« Reply #1 on: April 05, 2019, 09:57:23 AM »
Hi,

Please, check the 3ds Max's Plug-in Manager (Customize > Plug-in Manager...). Is the plug-in loaded? Are other plug-ins loaded correctly? Is the Additional MAX plug-ins checkbox marked? Any additional info is welcome. Thanks in advance for any further comments on this issue you can share about it with us / our user community.

Best regards,

BH1040

  • Newbie
  • *
  • Posts: 12
Re: Failure to Initialize
« Reply #2 on: April 05, 2019, 07:06:27 PM »
I do have problems.  No "Additional Plugins" header.  FP not loaded.

Edit:  I just copied the FPpro DLO file to the /stdplugs folder within Max 2016.  Now I get the software showing up in the Max /Create dropdown AND a floater window as well.

Am I creating a messy "hacked" install of the plugin?  Should I start over and re-install the plugin differently?
« Last Edit: April 07, 2019, 08:02:04 PM by BH1040 »

BH1040

  • Newbie
  • *
  • Posts: 12
Re: Failure to Initialize
« Reply #3 on: April 07, 2019, 08:00:18 PM »
While I'm waiting for expert advice on my DLO hack, I read through the Installation and Customisation document.

It appears I don't have the following files loaded.

User Interface Files   
<maxdir>\ForestQT.dll
<maxdir>\QtCore_Itoo_4.dll
<maxdir>\QtGui_Itoo_4.dll
<maxdir>\QtXml_Itoo_4.dll
<maxdir>\QtSolutions_MFCMigrationFramework-Itoo.dll

Is this my problem?

Michal Karmazín

  • iToo Software
  • Hero Member
  • *****
  • Posts: 1661
Re: Failure to Initialize
« Reply #4 on: April 08, 2019, 10:56:44 AM »
Hi,

In addition to the plug-in's .dlo itself, several files are needed for the proper plug-in functionality (like shaders etc.). Instead of copying the .dlo, configuring the "Additional MAX plug-ins" folder under Configure System Paths > 3rd Party Plug-Ins would be recommendable (attaching screen-shot). Hope that helps.

Best regards,

BH1040

  • Newbie
  • *
  • Posts: 12
Re: Failure to Initialize
« Reply #5 on: April 08, 2019, 07:36:46 PM »
How about the fact that the above DLL files are not found on my machine.  Shouldn't they have loaded when I installed FP 6?

Rokas

  • iToo Software
  • Hero Member
  • *****
  • Posts: 1626
    • iToo
Re: Failure to Initialize
« Reply #6 on: April 08, 2019, 08:49:48 PM »
When installing ForestPack do You get any errors? Do You see these files being copied? Can You find these files after reinstall?


Rokas
iToo Software

BH1040

  • Newbie
  • *
  • Posts: 12
Re: Failure to Initialize
« Reply #7 on: April 09, 2019, 06:55:56 PM »
I do not get any errors and yes,  all those files are present.

Success!  I believe I now have a clean install.  My last experience with Forest goes back to 2013 so I will refresh my knowledge. Thank you all for answering questions.

My next endeavor is to load the HQ Plants 2 library that I purchased 6 years ago.  Hope it works.
 
Cheers.
« Last Edit: April 09, 2019, 07:17:42 PM by BH1040 »