Itoo Software Forum

Author Topic: Forest 3D Preset map paths not configured correctly  (Read 343 times)

MU3245

  • Newbie
  • *
  • Posts: 31
Forest 3D Preset map paths not configured correctly
« on: July 05, 2021, 06:44:17 PM »
This has sort of plagued me for I don't know how long. Several years/releases or more.

Using 3DS MAX 2022 - Start a new project/scene. Make a plane. Create Forest Object with plane. Forest asks to configure/add map paths, choose yes. From Geometry Panel select Forest Library>Presets>Meadows (or Gravel or...other preset). It will create the forest and all looks good. Try making an adjustment with forest color. It does not work.

Save Scene. Close Max. Reopen Max. Get missing maps warning message. Now one must add in Max Configure Project Paths C:/users/user/appdata/local/itoosoftware/forest pack pro/  with include subfolders.

Now the Forest Object has the correct map path assignments and Forest color will work correctly and etc.

I think something is not configured correctly when first choosing yes to the automated Add forest Map Paths when first creating forest object. That does not correctly add the paths for Forest Presets. It uses legacy paths or I'm not sure what. This is tedious and has messed me up more than a few times.

It's usually me that causes these kind of things but this time I think there may be a legitimate glitch?

Finally took time to bring it to your attention. Thanks


Rokas

  • Hero Member
  • *****
  • Posts: 3326
Re: Forest 3D Preset map paths not configured correctly
« Reply #1 on: July 06, 2021, 09:37:13 AM »
Thanks for taking time to write this.
I have never had this myself, nor have seen this issue reported before.

When You are first presented with this dialog:


after pressing Yes, Your "Bitmaps paths" should be populated with all the necessary paths.
They should be seen in both 3dsmax.ini and "External Files" tab:

No max restart needed.

There might be some configuration conflict in Your PC.
Thanks in advance for any further comments on this issue you can share with us / our user community (in case some user(s) will run into similar troubles).
Rokas

MU3245

  • Newbie
  • *
  • Posts: 31
Re: Forest 3D Preset map paths not configured correctly
« Reply #2 on: July 06, 2021, 03:14:00 PM »
Thanks for your reply Rokas. I am now, predictably, thinking the problem is indeed at my end.

I created a new blank scene. Then before creating a forest object or doing anything else I looked at Configure Project Paths. Screengrab attached.

Somehow, some unknown time ago, it appears that i took steps to cause Max to custom-populate project paths on new startup. I think that is the cause of this problem.  I need to determine how to fix that.

Thanks again for your help!


MU3245

  • Newbie
  • *
  • Posts: 31
Re: Forest 3D Preset map paths not configured correctly
« Reply #3 on: July 06, 2021, 06:06:24 PM »
Oh boy. I don't know what I have done but I hope you can help me get it sorted and back to the intended default behavior.

In Max 2022 I create new default project. Save new empty scene. Configure Project Paths appears as in screengrab02 below.

Create plane and convert to poly. Create Forest Pro preset meadow. Select yes to"add forest paths" pop up.

Configure Project Paths now appears as in screengrab03 below.

Save, close and then reopen scene. Get missing map files window shown in screengrab04. WTF?

Finally - screengrab05 shows the contents of the projects .mxp created by Max




Rokas

  • Hero Member
  • *****
  • Posts: 3326
Re: Forest 3D Preset map paths not configured correctly
« Reply #4 on: July 06, 2021, 08:44:03 PM »
First I want to be sure You are not using old versions of 3ds max and vray as that combo has an error- not saving max settings on exit.

Would You please confirm that both latest versions are installed ?
Rokas

MU3245

  • Newbie
  • *
  • Posts: 31
Re: Forest 3D Preset map paths not configured correctly
« Reply #5 on: July 06, 2021, 08:51:06 PM »
Using 3DS Max 2022.1 
Vray 5 update 1.1
Windows 10 with current updates

Rokas

  • Hero Member
  • *****
  • Posts: 3326
Re: Forest 3D Preset map paths not configured correctly
« Reply #6 on: July 06, 2021, 09:06:17 PM »
Can You try adding some paths manually, without forest pack and restart. Are they gone after restart as well?
« Last Edit: July 07, 2021, 08:56:31 AM by Rokas »
Rokas

MU3245

  • Newbie
  • *
  • Posts: 31
Re: Forest 3D Preset map paths not configured correctly
« Reply #7 on: July 06, 2021, 09:23:07 PM »
I added some paths manually and then re start. The paths I added manually are there on re start, as they should be.

The problem seems to be that when I create a new forest object and then accept the forest pop up about adding the forest paths. Somehow additional paths to my custom create directories are also added. That is shown in screengrab03.jpg in my previous post above.

Thank you for your ongoing help.

Rokas

  • Hero Member
  • *****
  • Posts: 3326
Re: Forest 3D Preset map paths not configured correctly
« Reply #8 on: July 07, 2021, 08:58:06 AM »
I would suggest You open 3dsmax.ini file with notepad++ or some other editor which refreshes file after it gets changed and monitor what is the moment when the paths gets deleted? maybe it will give any clue.
Rokas

MU3245

  • Newbie
  • *
  • Posts: 31
Re: Forest 3D Preset map paths not configured correctly
« Reply #9 on: July 07, 2021, 02:21:31 PM »
I am sorry but I think I am not explaining this very well. It does not seem to be a problem of having paths getting removed, but rather having extra conflicting paths included when forest pack first configures the project paths.

To repeat:
The problem seems to be that when I create a new forest object and then accept the forest pop up about adding the forest paths. Somehow additional paths to my custom create directories are also added. That is shown in screengrab03.jpg (second image in the attachments sequence) in my previous post above.


Please look at the post above with the screen grab sequence. NOTE the first screengrab is labeled screengrab02, then 03

Rokas

  • Hero Member
  • *****
  • Posts: 3326
Re: Forest 3D Preset map paths not configured correctly
« Reply #10 on: July 07, 2021, 02:42:08 PM »
would You please attach a window of Your Library browser preferences:


I suspect those folders are added in there.
Rokas

MU3245

  • Newbie
  • *
  • Posts: 31
Re: Forest 3D Preset map paths not configured correctly
« Reply #11 on: July 07, 2021, 03:54:17 PM »
OK I get it. Those directories should be added by forest because they are part of my user created Library structure.

Now I am seeing something that may be the problem. Look at my screengrab03 above. The map directory paths added by forest include:

Users/Mark/AppData/Local/Itoo Software/Forest Pack Pro/maps.

BUT - the paths added do not include any of the sub folders that are under Users/Mark/AppData/Local/Itoo Software/Forest Pack Pro/maps, Those sub folders are: Classic, HShadows, Presets (most important) and Standard. Those sub folders are where the maps reside for the Forest Meadow presets and other presets I tend to use frequently. They are not being added to Configure Project Paths by forest upon initial forest object creation.

So the maps in those folders are not being added and I now believe that is the source of my long standing and ongoing problem. It is however hard to understand why I am the only user this seems to be happening to.

« Last Edit: July 07, 2021, 04:13:38 PM by MU3245 »

Rokas

  • Hero Member
  • *****
  • Posts: 3326
Re: Forest 3D Preset map paths not configured correctly
« Reply #12 on: July 07, 2021, 05:48:37 PM »
OK, seems You found the issue. There should be no subfolders in that folder:
Rokas

MU3245

  • Newbie
  • *
  • Posts: 31
Re: Forest 3D Preset map paths not configured correctly
« Reply #13 on: July 07, 2021, 06:11:40 PM »
OK. So I keep updating to the current versions of FP but those folders keep getting added? Or they are somehow left from an older version and not removed when updating FP?

I should move the contents of all those sub folders so they live under the /maps directory and delete those sub folders?

thank you.

Rokas

  • Hero Member
  • *****
  • Posts: 3326
Re: Forest 3D Preset map paths not configured correctly
« Reply #14 on: July 07, 2021, 06:23:34 PM »
try uninstall packages with update manager, check that folder structure, and then install using update manager.
Rokas