Itoo Software Forum

Author Topic: Forest dual install  (Read 448 times)

TATproductions

  • Newbie
  • *
  • Posts: 31
Forest dual install
« on: June 17, 2019, 12:14:55 PM »
Hello

We  have currently 2 productions with both different version of forest.
I have a production with 3dsmax 2016, vray 3 & forest 5.4.1 and a new one with 3dsmax 2020, Vray Next and forest 6.2.

This is a absolute nightmare to manage 2 versions of Forest in parallel.
If i try to isntall manually, i can keep the old one.
I've made .bat to copy files (.dlo ...) but even like that when i try to render, i have alerts notifying that i don't have the good Vray version....

Where Forest is looking at the Vray version before rendering ?
Do you have any advice for having a good workflow with 2 different Forest installation.
Please consider improving this user case. This is critical for medium studio like us using Forest.

Thanks !
-p-




Michal Karmazín

  • iToo Software
  • Hero Member
  • *****
  • Posts: 1736
Re: Forest dual install
« Reply #1 on: June 17, 2019, 02:35:03 PM »
Hi,

The "Install FP5 and FP6 at the same time on different Max versions" thread should help.

Best regards,

TATproductions

  • Newbie
  • *
  • Posts: 31
Re: Forest dual install
« Reply #2 on: June 17, 2019, 03:48:49 PM »
Ah that was the topic i was looking for... i knew i already had posted on this forum about this problematic.  ;D

Unfortunately, i can't use solution #1 because it require manual actions (folder renaming...) and i need to massively deploy it.
 
I am using the solution #2 and it works... until you render.
I've install FP5 for 2016 with .exe, then install FP6 for 2020 by copying files....  FP6 is working fine, but  now FP5 for 2016 is buggy when rendering. Looks like it's looking for a vrayNext render (while i'm on 3.6 for 2016) but i can work on the forest in viewport.

It's just like if that Forest is looking for an environment variable (like LAST_VRAY_VERSION or whatever) before rendering....


iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3623
    • iToo Software
Re: Forest dual install
« Reply #3 on: June 18, 2019, 08:43:35 AM »
Hi, Forest tries to load the ForestVRay??.dll files (there are several of them, for each V-Ray version). When one of then matches with the current V-Ray version, it's used.
These DLLs are installed in the 3DS Max root folder.

So, for render nodes, you must copy ForestPackPro.dlo file in the "plugins" folder, and all ForestVRay??.dll in the 3DS Max root folder.
For reference, the full list of files is describe here.

Please note that if Windows cannot find the V-Ray DLLs in the Max root folder, it searches them in the directories defined by the PATH variable. (this is a standard behaviour for the DLL loading)
I guess in this case Windows is loading the wrong DLLs from other folder defined in PATH, because they doesn't exist in the 3DS Max root.

Carlos Quintero
iToo Software

TATproductions

  • Newbie
  • *
  • Posts: 31
Re: Forest dual install
« Reply #4 on: June 18, 2019, 10:06:14 AM »
Indeed, it looks like that i forget to copy both DLL ForestVRay37.dll & ForestVRay40.dll. My bad.

now it's working ! 
thanks :)