Itoo Software Forum

Author Topic: Forest effect for displaced geometry not working  (Read 624 times)

Arqrenderz

  • Newbie
  • *
  • Posts: 14
Forest effect for displaced geometry not working
« on: March 31, 2024, 11:10:32 PM »
Im trying to use the forest effect for displaced geometry with corona but its not following the surface
Attached the scene

using corona 11.1  3dsmax 2023.3.4  And Forest 8.2.5

Michal Karmazín

  • iToo Software
  • Hero Member
  • *****
  • Posts: 2520
Re: Forest effect for displaced geometry not working
« Reply #1 on: April 02, 2024, 02:41:31 PM »
Hi,

The "Follow Displaced Surface (Corona)" effect is designed to be used in the UV mode (it evaluates the fpItem.distUVW values). If you want to use the XY Surface mode, you can use the "previous" version of such an effect, which reads the "Color Tint" values (fpItem.tintColor.x) from the Material rollout. That should work just fine. Please find attached the modified scene (240402_ForestDisp_iToo.max).

I hope this helps.

Best regards,

Arqrenderz

  • Newbie
  • *
  • Posts: 14
Re: Forest effect for displaced geometry not working
« Reply #2 on: April 02, 2024, 07:22:32 PM »
Hi Michal
Thx for the quick answer, i can see the effect working in the file you send
now im trying to do the same with a corona distance map and cant get it to work, attached a few screenshots and the basic file to know where im losing it..

Michal Karmazín

  • iToo Software
  • Hero Member
  • *****
  • Posts: 2520
Re: Forest effect for displaced geometry not working
« Reply #3 on: April 03, 2024, 09:09:11 AM »
Please find attached the modified scene (240403_ForestDispCoronaDistance_iToo.max) when I've again used the approach mentioned above. Just let me mention that Forest's gizmo should be located in the center of 3ds Max's world coordinates to get the CoronaDistance map to work properly. I hope that helps.

Best regards,