Itoo Software Forum

Author Topic: Forest Library Not Including Some Maps  (Read 449 times)

MU3245

  • Newbie
  • *
  • Posts: 44
Forest Library Not Including Some Maps
« on: May 03, 2024, 06:31:42 PM »
I have my forest library with numerous individual libraries. all are set up the same way and most work as they should. I have a few libraries that when I use in a scene the folder with the maps is not found. I then in 3DS Max use "customize project paths" to add the path to the map folder and that works.

I am unsure why for a few of these libraries the maps folder is not automatically found like it is with the rest of my libraries.

What do I need to do so that the Forest Library recognizes/finds these map folders.

Example screen shot is attached. Thanks!

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 4440
    • iToo Software
Re: Forest Library Not Including Some Maps
« Reply #1 on: May 04, 2024, 08:59:15 AM »
Hi,

With our libraries, we include a small script to add the texture path to 3DS Max automatically.

But according to your screenshot, this is a library from Vizpark, a third party creator.
Probably they don't include a similar script in their packages. This is optional, because each vendor may configure their libraries in different ways.

Besides this, Forest includes a mechanism to scan all libraries, searching for folders named 'maps', and add them to 3DS Max.
For performance reasons, in the latest releases this process is applied only to the builtin libraries, but not to the user libraries.
This may be configured at Library Browser->Preferences,as shown in the attached image.

Anyway, if you have already added the texture path manually, it's not necessary any further step.

« Last Edit: May 04, 2024, 09:06:50 AM by iToo »
Carlos Quintero
iToo Software

MU3245

  • Newbie
  • *
  • Posts: 44
Re: Forest Library Not Including Some Maps
« Reply #2 on: May 04, 2024, 05:09:12 PM »
Thank you Carlos! That was just what was needed. I wanted to have those maps folders automatically included  going forward.Running that process seems to have done the trick.

thanks again!