Itoo Software Forum

Author Topic: Forest Objects set to invisible to camera, still render bits  (Read 388 times)

Morne

  • Full Member
  • ***
  • Posts: 131
Forest Objects set to invisible to camera, still render bits
« on: March 01, 2022, 04:01:52 PM »
I've been having this problem for years, and usually found workarounds in post. However I need a better solution now
(its easily reproducible)

When you set forest objects to not be visible to cam (so you only want its shadow to render), then bits of it is still visible)

Current setup:
Max version: 2022 update3
VRay: 5.20.02
ForestPack: 7.3.1

Paul Roberts

  • iToo Software
  • Hero Member
  • *****
  • Posts: 2567
Re: Forest Objects set to invisible to camera, still render bits
« Reply #1 on: March 01, 2022, 04:16:47 PM »
Hi Morne,

Thanks for reporting the issue. I tried it with a quick scene here but it seems to work OK.



Could you reproduce the issue in a sample scene for me? Also, if you convert the FP object to instances, does the problem persist? That's a good way of checking to see if it's an FP problem or something more general.

Cheers,

Paul
Paul Roberts
iToo Software

Paul Roberts

  • iToo Software
  • Hero Member
  • *****
  • Posts: 2567
Re: Forest Objects set to invisible to camera, still render bits
« Reply #2 on: March 01, 2022, 04:21:21 PM »
Not to worry - I think I can reproduce it. I'll pass it over to the development team.



Thanks
Paul
Paul Roberts
iToo Software

Morne

  • Full Member
  • ***
  • Posts: 131
Re: Forest Objects set to invisible to camera, still render bits
« Reply #3 on: March 01, 2022, 04:22:17 PM »
Yes, that is exactly the type of thing I'm getting, sometimes worse than others

RealViz

  • Full Member
  • ***
  • Posts: 195
Re: Forest Objects set to invisible to camera, still render bits
« Reply #4 on: March 02, 2022, 06:24:34 AM »
I think you need to set more "max transp. levels" in the renderer.

Morne

  • Full Member
  • ***
  • Posts: 131
Re: Forest Objects set to invisible to camera, still render bits
« Reply #5 on: March 03, 2022, 01:13:01 PM »
Any news form the devs Paul? It also affects the alpha channel in a strange way. Where its incrorrectly visible in diffuse, it knocks out the alpha channel even if there's geometry behind it

Paul Roberts

  • iToo Software
  • Hero Member
  • *****
  • Posts: 2567
Re: Forest Objects set to invisible to camera, still render bits
« Reply #6 on: March 03, 2022, 01:16:46 PM »
It's been reported, but it'll take a while to investigate. Meanwhile, RealViz's suggestion to increase V-Ray's  Max Transparency Levels setting seems to fix it.

Cheers,
Paul
Paul Roberts
iToo Software

TATproductions

  • Newbie
  • *
  • Posts: 38
Re: Forest Objects set to invisible to camera, still render bits
« Reply #7 on: May 31, 2022, 12:22:39 PM »
Hello

We regularly have this problem in production. (3ds 2021.3, forest 6.3.1)
This could be easily reproductible with teapot.

The fact that, when converting the forest into instance does resolve the problem, confirm that it comes from Forest more than Vray no ?





TATproductions

  • Newbie
  • *
  • Posts: 38
Re: Forest Objects set to invisible to camera, still render bits
« Reply #8 on: June 01, 2022, 03:16:33 PM »
For information, same problem with 3ds 2022.3 & Forest 7.4.1

Paul Roberts

  • iToo Software
  • Hero Member
  • *****
  • Posts: 2567
Re: Forest Objects set to invisible to camera, still render bits
« Reply #9 on: June 01, 2022, 03:21:28 PM »
I've just had a chat with the development team and apparently we don't handle the 'no visible' flag in any way. It's all handled on the V-Ray side. On top of this, V-Ray itself has specific code for Forest objects (optimizations, workarounds and so) that remain unknown to us. It's probably worth reporting this to the V-Ray team too.

Cheers,
Paul
Paul Roberts
iToo Software