Itoo Software Forum

Author Topic: Forest Pack Distribution Map: Multitexture or VrayMultisub texture not working  (Read 1312 times)

KN1988

  • Newbie
  • *
  • Posts: 22
Hi,

I have 1 object with multiple elements with randomized material ID's.
On this surface I want to use Forest pack.

I want to use multiple bitmaps in 1 map to define the distribution map.
I wanted to distribute the objects by using the "multitexture map" from CG source or the "VraymultiSub texture map".
BUT: both of them only show & work on the first map! They also only show the first map in the viewport (this is normal. might that be the problem?)

Thanks for the quick answer.
Kind regards,




KN1988

  • Newbie
  • *
  • Posts: 22
Addition: It also doesn't work for the Color ID map in the "Diversity" section. So My guess is that the problem is the map type?
Is there a possible solution for this (that doesn't involve unwrapping an render to texture...)

Thanks and kind regards,

Michal Karmazín

  • iToo Software
  • Hero Member
  • *****
  • Posts: 1475
Hi,

Unfortunately, MultiTexture (CG Source) / VRayMultiSubTex will not work as Distribution map in Forest Pack, because they are computed at render time, but scattering process is done in a previous stage.

Anyway, would you please post an example how the distribution should look like? Thanks in advance. I would suggest "baking" the map to texture, but maybe there will be another workaround ...

Kind regards,

KN1988

  • Newbie
  • *
  • Posts: 22
Thanks for the quick reply. I understand. I already thought this was the case.
If it is impossible to get the mulitexture map or vray multisub map working, then the quickest way would probably be baking.
To bad. I really wanted to automate this process....
Attached is a simple test scene I've made for this. Please take no notion of the textures etc. It is just for test purposes.

Would be great if there is a possible solution that doesn't involve baking the textures.

Best regards,

KN1988

  • Newbie
  • *
  • Posts: 22
Hello,

I presume there is no solution for this except baking?

Thanks and kind regards,

Michal Karmazín

  • iToo Software
  • Hero Member
  • *****
  • Posts: 1475
Hi,

Please apologize the delay. Have been trying to find some another workaround, but I'm afraid the rendering process needs to be involved (baking it).

Best regards,

KN1988

  • Newbie
  • *
  • Posts: 22
Shit. I was afraid of this.
Thanks. If you do find a solution in the future (maybe in a plugin / script or something) I'd really like to know.

Thanks again.
Best regards