Itoo Software Forum

Author Topic: getFulltransform always returns same matrix  (Read 1344 times)

GH4155

  • Newbie
  • *
  • Posts: 6
getFulltransform always returns same matrix
« on: July 21, 2014, 02:27:36 PM »
Hello Michal,

this is the continuation for this topic: http://forum.itoosoft.com/index.php?topic=2278.0. I still can't get the transformations for the single trees in my forest object.

Best Regards,
Chris

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3151
    • iToo Software
Re: getFulltransform always returns same matrix
« Reply #1 on: July 21, 2014, 04:25:50 PM »
Hi, i think we've found the problem: are you using Custom Edit mode with Camera Clipping ? If so, try disabling clipping.

The hidden items in Custom Edit mode are not processed correctly by the Maxscript functions. Although they exist internally in Forest, their values are not updated completely and getFullTransform returns incoherent results.

I've logged the bug in our to-do list.
Carlos Quintero
iToo Software

GH4155

  • Newbie
  • *
  • Posts: 6
Re: getFulltransform always returns same matrix
« Reply #2 on: July 22, 2014, 01:09:20 AM »
Hi Carlos,

thanks for your answer. Unfortunately i'm neither in Custom Edit mode, nor do i have Camera Clipping enabled. I just do these following steps:


result:
each tree returns "(matrix3 [1,0,0] [0,1,0] [0,0,1] [0,0,0])"

The whole time i'm not in Custom Edit mode also disabling camera clipping does not change the result in any way. I've tried several different machines and two major max versions (2012 and 2014) - no dice. Like i wrote in the first thread i need the full transformation (position, rotation and scale) to instance some trees in a realtime engine so i'm open to other workarounds, but there's got to be some way, right?

Best Regards,
Chris

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3151
    • iToo Software
Re: getFulltransform always returns same matrix
« Reply #3 on: July 22, 2014, 09:27:31 AM »
Ok, i see the problem.

Initially this function was designed to get the transform of the instantiated items (Custom Objects), so it doesn't work with billboards.
Please, try changing to Custom Object in the Geometry settings (you must assign a temporary object as well). That must solve the problem.
Carlos Quintero
iToo Software

GH4155

  • Newbie
  • *
  • Posts: 6
Re: getFulltransform always returns same matrix
« Reply #4 on: July 22, 2014, 03:48:36 PM »
OMG, thanks. I thought i'd try with a minimal setup so i didn't even consider using Custom Objects. Thanks for clearing that up! Everything working as expected now.  :)

Best Regards,
Chris