Itoo Software Forum

Author Topic: Horizontal Shadows on objects  (Read 3749 times)

UF7753

  • Newbie
  • *
  • Posts: 24
Horizontal Shadows on objects
« on: November 26, 2007, 03:40:46 PM »
the horizontal shadows do not cast across objects. the vertical do as you can see from the image below. so is there something i'm missing or is this a limit of forest pro at the moment?


iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3315
    • iToo Software
Re: Horizontal Shadows on objects
« Reply #1 on: November 26, 2007, 07:52:09 PM »

We cast horizontal shadows using a fake plane, placed by default at 5% of the tree's height from the base of it. So, the objects above of this plane are out of the shadow area.

Try increasing the Z Offset value in the shadow parameters, to move up the shadow plane. Although this fix is very dependent of the scene, may be useful in some situations.

Carlos Quintero
iToo Software

UF7753

  • Newbie
  • *
  • Posts: 24
Re: Horizontal Shadows on objects
« Reply #2 on: November 27, 2007, 12:53:08 PM »
thanks for the reply. i will try this later when i get a chance. i do not plan to place objects in this position often and i suppose i could leave off the horizontal shadow as an option.
if i remember correctly, when i increased the z% the shadow started to move in the direction that the light creating the shadow was pointing. i could create another directional light pointing straight down to cast the horizontal shadow, so when i increase the z% it will not move in the (x,y) axis. if this works i'll post back.

UF7753

  • Newbie
  • *
  • Posts: 24
Re: Horizontal Shadows on objects
« Reply #3 on: November 27, 2007, 03:31:31 PM »
some success. i found that using a second light with raytrace shadows for the horizontal shadow works in the sense you can increase the z% without the shadow moving in the x,y plane. i had to vary the shadow density to get the xshadow to a similar raytrace shadow.
this is probably getting a little complex, because i need to add another light for GI and 3 lights are 1 too many, i think.