Itoo Software Forum

Author Topic: I have a work problem  (Read 419 times)

weesun

  • Newbie
  • *
  • Posts: 6
I have a work problem
« on: December 28, 2020, 01:52:08 PM »

Today I made a hedge. Then I want to follow the picture to indicate that there are some fallen leaves on the hedge. But I found that I can't add fallen leaves to the forest creation. Is there any way to solve it?

Michal Karmazín

  • iToo Software
  • Hero Member
  • *****
  • Posts: 1743
Re: I have a work problem
« Reply #1 on: December 28, 2020, 02:16:27 PM »
Hi,

Well, hedges and topiary often require a bit different approach and I would suggest you check the following tutorial (in available tutorial files you can find some examples): https://www.itoosoft.com/tutorials/creating-trimmed-hedges-and-topiary

By using this way, you can simply add these "leave items" to the Geometry list and adjust as needed. I hope that helps.

Best regards,

weesun

  • Newbie
  • *
  • Posts: 6
Re: I have a work problem
« Reply #2 on: December 28, 2020, 02:48:29 PM »

Maybe I didn't explain it. Sorry. I mean the first step, I made a circle of plants first. Then I want to put some fallen leaves on this plant. Not that there are yellow leaves on this circle of plants. Can you understand this way? As shown in the attached picture.

Michal Karmazín

  • iToo Software
  • Hero Member
  • *****
  • Posts: 1743
Re: I have a work problem
« Reply #3 on: December 28, 2020, 03:10:43 PM »
Hi,

The Forest Pack uses the Item's (Custom Object's) Pivot Point position (which might be later adjusted by the Geometry - Custom Object - Z Offset value). I would suggest you to:
  • Select the "Custom Object" (Select Forest Custom Object) and on the Hierarchy tab - Adjust Pivot select the Affect Pivot Only option.
  • Move the Pivot Point to the desired position (Align tool - Ctrl+A could be very handy to perform that automatically as in most cases its Z Position should be moved to the Minimum - in this case it should be a bit "lower").
That should help.

Best regards,

weesun

  • Newbie
  • *
  • Posts: 6
Re: I have a work problem
« Reply #4 on: December 28, 2020, 03:36:22 PM »

Thank you for your answer. Could your company improve the software? You can continue to add objects on the forest surface. In this case, it is even more perfect. Thank you

Rokas

  • iToo Software
  • Hero Member
  • *****
  • Posts: 2922
    • iToo
Re: I have a work problem
« Reply #5 on: December 30, 2020, 08:12:15 AM »
Hi weesun

That is possible already:



WARNING!
Just please understand that second forest pack must analyze 1st forestpack geometry, and that can become quite complex with many bushes scattered, so please use with caution(and save file before attempting), on small areas/not to high density poly objects.


How to do it:
on Your bush forest object, set Render Mode to Meshes (1) instead of automatic, and second, but not necessary step to set Display -> Viewport "Mesh" as well (2).


Then create second Forest Object for leaves, using First Forest Object as its surface.

Hope this helps.

« Last Edit: December 30, 2020, 08:15:53 AM by Rokas »
Rokas
iToo Software

weesun

  • Newbie
  • *
  • Posts: 6
Re: I have a work problem
« Reply #6 on: December 30, 2020, 08:46:44 AM »

Thank you! Let me try。
I am from China and my English is not very good. Need to use translation tools. See you have done it. It feels great! :-*