Itoo Software Forum

Author Topic: Large plane rendering some very basic grass models, 61k models in total but SLOW  (Read 788 times)

steve3duk

  • Newbie
  • *
  • Posts: 14
I have a large plane with camera visibility only. Forest pro is only having to render 61k very low poly grass models but it seems to take into consideration everything on the plane at calculation time for some reason. The setup time is at least 5 mins.

Even if I reduce the distribution down to 6k models the setup seems to be way more than it should be. I can never get dense grass in scenes using large planes.

Is there a way to speed this up?

Paul Roberts

  • iToo Software
  • Hero Member
  • *****
  • Posts: 2457
Those times don't sound right to me. Are you able to share a stripped scene with helpdesk@itoosoft.com so we can check out the issue in more detail?

Thanks,
Paul
Paul Roberts
iToo Software

steve3duk

  • Newbie
  • *
  • Posts: 14
So, the problem seems to be if I use any other map apart from FULL in the distribution map. If I use patches or a noise map in the map texture slot the memory usage goes sky high..even though there are less items being rendered. What is the issue here and what is a method around it? It seems very odd that using a map where actually less items will be rendered because of the black areas would suddenly cause an issue with memory usage...
« Last Edit: March 13, 2022, 10:49:15 PM by steve3duk »

Paul Roberts

  • iToo Software
  • Hero Member
  • *****
  • Posts: 2457
It's really hard to see what the issue is without being able to reproduce it. Those times seem unusual to me, changing the distribution maps shouldn't make a significant difference and I can't reproduce those times easily here. Would it be possible to get hold of a stripped file that reproduces the issue? It'd really help us to isolate the issue. You can send it to helpdesk@itoosoft.com

A few things you can check.

- Are collisions enabled? If so turn consider turning them off
- Be aware that Forest Pack processes each pixel on a map so just because one doesn't produce an object, doesn't mean that Forest Pack didn't have to parse it. It can be quite inefficient to create huge dense scatters using very sparse maps. It's much better to use a denser map where you can.
- Is the surface very high poly? If it is, try to avoid enabling auto-update if possible.
- Once a distribution is acceptable, it's possible to Convert to Custom Edit mode which will bake in the distribution and remove any future calculation times.

Many thanks,

Paul
Paul Roberts
iToo Software