Itoo Software Forum

Author Topic: Licensing server issue - Licence active, but forest won't find it.  (Read 1451 times)

TP2586

  • Newbie
  • *
  • Posts: 2
Hello,

I have an issue with my computers that i don"t get.
The 3 of them were running an old version of max (2017) and forest(5.4).
We updated them and took a renewal for forest in order to make it work with max2020.

Issue is that now, forest is unable to find any licence while server licence is ON and licence is shown active... Now even my old max can't launch forest.
I'm sure it's temporary but it's damn frustrating. Hopefully one day it will be done simply by having an online check
(i think i have seen that it is something that is for real on the roadmap, and i support that a lot)

My questioni is: as logs show totally nothing, as max can't find the licence and as the licence is showing active when looking at the server licence...What can i do??
I'm using (trying to) last version of forest and licence server.
I've tried running everything as admin, rebooting all also...
Licence server don't seem to do anything when pressing start server on the server tab. And because of that, logs are empty. (so can't send them to you)
(i see a "connected" title on the bottom of the window, but nothing happens, and still no licence found by max)


Any Idea? What did i do wrong?
Could there be an old licence server hidden in the network somewhere saying that there is no licence ?

By advance thanks.

Michal Karmazín

  • iToo Software
  • Hero Member
  • *****
  • Posts: 1736
Re: Licensing server issue - Licence active, but forest won't find it.
« Reply #1 on: November 22, 2019, 08:57:59 AM »
Hi,

During the installation, the Itoo Software License Manager 1.2 should be replaced by version 1.4, but might be, that uninstall process failed for some reason - please feel free to remove the previous version and double-check, that there's no other installation of the License Manager on your computer.

Also, I would suggest you set the IP of the server "manually" rather than finding it automatically. That can be done during the installation or by using the "Change License Mode" wizard after setting the Network license mode in the Configure the Network License window.

The right network configuration is always very specific for any network and the correct set-up of the connection will depend on all firewall/anti-virus solutions you are using. Basically, you'll need to open the port 16720 on license server & workstations. It must be open both for TCP and UDP.

Thanks in advance for any further details you can share about it with us / our user community (in case some user(s) will run intosimilar troubles).

Best regards,

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3623
    • iToo Software
Re: Licensing server issue - Licence active, but forest won't find it.
« Reply #2 on: November 22, 2019, 05:06:54 PM »
There is a bug in the latest License Server (1.4.0) which doesn't show correctly the log. Although this doesn't affect to the functionality of the server itself.

Please, modify the following registry key in the computer which is running the server (use the Windows Registry Editor as Administrator):

HKEY_LOCAL_MACHINE\SOFTWARE\Itoo Software\License Server
Set the logFile key to  C:\ProgramData\Itoo Software\licserver.log

Once changed, restart the License Manager and the log should be accessible. I suggest also to enable the debug mode in the Server, as described here.
Please, send us the log content to identify what is the problem.

Thanks,
Carlos Quintero
iToo Software

TP2586

  • Newbie
  • *
  • Posts: 2
Re: Licensing server issue - Licence active, but forest won't find it.
« Reply #3 on: November 25, 2019, 05:58:41 PM »
Hello, and back to my issue.

I had a good instinct, it was an old version of license manager which was installed in a remote dark place of our server.
It was preventing other managers to take initiative, and was stuck with our old licence info.

So issue was on our side, as i was guessing first. (as 75+% of requests i imagine)
Main issue for me was to have access to our network and do what was needed (meaning kill old manager services and install new one in a easier place to find and access).
Took us 2 full days, 'cause IT was not available.

All working now.

Thanks for the answers i tried manual adressing and such, but with a ghost ninja ancient hidden license manager trolling, it wasn't an option.

Rokas

  • iToo Software
  • Hero Member
  • *****
  • Posts: 2669
    • iToo
Re: Licensing server issue - Licence active, but forest won't find it.
« Reply #4 on: November 25, 2019, 06:01:23 PM »
Glad it is solved now.
Thanks for an update ;)
Rokas
iToo Software