Itoo Software Forum

Author Topic: Materials assignment issues when adding custom object  (Read 1028 times)

DM5847

  • Newbie
  • *
  • Posts: 38
Materials assignment issues when adding custom object
« on: January 31, 2023, 08:09:08 PM »
Hi,

We seem to be running into a materials assignment issue that seems to have started with an FP update.

- When adding custom objects to a forest pack it will not automatically assign the custom objects material.
- When replacing a custom object with another custom object the materials don't update and it keeps the old one.

The above issue means we are consistently having to manually add the object materials. Until recently this worked automatically. Have we missed a check box somewhere in the latest version(s) that sorts this out?

Thanks!

Michal Karmazín

  • iToo Software
  • Hero Member
  • *****
  • Posts: 2587
Re: Materials assignment issues when adding custom object
« Reply #1 on: February 01, 2023, 10:30:23 AM »
Hi,

In recent versions, the V-Ray renderer now uses “directly” material(s) assigned to each Custom Object (there isn't any material assigned under Forest's Geometry > Material). Once you manually assign any material to Forest's Geometry > Material (which unless you want to use another material isn’t really needed), it would remain there until it’ll be replaced by another one or by the Clear button. I hope that clears it up.

Best regards,

CM1251

  • Newbie
  • *
  • Posts: 25
Re: Materials assignment issues when adding custom object
« Reply #2 on: February 01, 2023, 03:20:11 PM »
Does the same happen with Corona? I've noticed when I add custom objects, I have to add their material to the FP object slot manually. Otherwise replacing objects from the browser updates said material like it should.

Michal Karmazín

  • iToo Software
  • Hero Member
  • *****
  • Posts: 2587
Re: Materials assignment issues when adding custom object
« Reply #3 on: February 01, 2023, 03:36:49 PM »
Hi,

Thanks for your swift reply. Yes, in the case of the Corona renderer, it works in the same way – the used material isn’t imported – instead, it’s getting the material directly from the Custom Object(s) and upon our tests here it seems to work just fine.

Best regards,