Itoo Software Forum

Author Topic: Mental Ray shadow and light problems  (Read 3016 times)

silnod1

  • Newbie
  • *
  • Posts: 1
Mental Ray shadow and light problems
« on: July 16, 2007, 08:32:27 PM »
Hi, I'm working on populating a very large highway with trees. The problem I am having is that when I use mental ray to render I dont see any shadows from the trees, and the trees become very dark, to the point where they look black. I looked at my material list and compared it to what I see on the site but I still have these problems. I have two screenshot, is there a place I can send them for you guys to look at?

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3156
    • iToo Software
Re: Mental Ray shadow and light problems
« Reply #1 on: July 16, 2007, 09:45:33 PM »
Hi,

Please, send it to support@itoosoft.com. Also, a test scene (with only the needed objects) will be very useful to find the problem.
If the files are too big to attach, contact me by email to send you a private ftp address to upload them.

Carlos Quintero
iToo Software

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3156
    • iToo Software
Re: Mental Ray shadow and light problems
« Reply #2 on: July 18, 2007, 06:00:27 PM »
Quote
I attached a scene file that I stripped everything out of except the lighting and the trees. Basically I am using mental ray and for some reason I cant get the trees to light up. Even if I turn up the self illumination the material is still dark. I am also noticing that no shadows are being cast by the trees and that some trees look like there just black squares, which seems odd since all the trees are using the same planes configuration and texture. Any help would be much appreciated, thanks.

After playing for a while with your scene, i have found the problem (a compatibility issue with HDR). We must write a patch for Planes Material, but this may take some time. As workaround, you may increase the 'RGB level' in the Bitmap to get a brighter texure (use a value of 20 or so).
 
This is only needed with lights that use HDR (as 'Daylight' or 'mr Sun' types).
 
To get the shadows, you must Pick the light in the 'Shadow' parameters of Forest. This parameter was empty in your scene.
 
Tip: if you get some black holes between trees when using Mental Ray, try increasing the 'Max.Depth' and 'Max.Refractions' values in the Renderer->Ray Tracing parameters. The default values are too low for scenes that use a lot of overlapped opacity textures (as Forest)
 
Carlos Quintero
iToo Software