Itoo Software Forum

Author Topic: Network renders slaves crash since last software update  (Read 1076 times)

LL4733

  • Newbie
  • *
  • Posts: 14
Network renders slaves crash since last software update
« on: June 27, 2015, 10:24:55 AM »
Hello,

Since we have updated our workstations and render slaves to 4.4.0, most of the time the render slaves crash during the loading of the scene.
We receive the "unexpected error, the pipe has ended - error".

Strange thing: When we include the workstations in the network render, these machines render just fine, while the slaves crash.

We have copied all of the the forest pack maps to the max/maps directory of the render slaves and even replaced the FShader3.dll as suggested in another thread. Nothing helps.
« Last Edit: June 27, 2015, 12:16:03 PM by LL4733 »

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3319
    • iToo Software
Re: Network renders slaves crash since last software update
« Reply #1 on: June 27, 2015, 12:32:12 PM »
Hi, apologies for the inconveniences.
What Max version do you use ? We'll try to reproduce the problem here.
Carlos Quintero
iToo Software

LL4733

  • Newbie
  • *
  • Posts: 14
Re: Network renders slaves crash since last software update
« Reply #2 on: June 27, 2015, 01:43:59 PM »
3dsmax 2016 and 3dsmax 2015.
Workstations and most of the render slaves are on Windows 7 64bit
We have 2 floating network licences of Forest Pack. (Tecton Interactive)



LL4733

  • Newbie
  • *
  • Posts: 14
Re: Network renders slaves crash since last software update
« Reply #3 on: June 27, 2015, 01:55:51 PM »
This is the typical error we get.
(This was a test with one simple plane and a "standard" forest pack lawn preset.)

LL4733

  • Newbie
  • *
  • Posts: 14
Re: Network renders slaves crash since last software update
« Reply #4 on: June 27, 2015, 02:15:02 PM »
If this error can't be solved, is it possible to uninstall the 4.4.0 version and go back to the previous version? (and resave the current job as 3dsmax 2015) Or will this generate new problems for the files edited with the 4.4.0 version?

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3319
    • iToo Software
Re: Network renders slaves crash since last software update
« Reply #5 on: June 27, 2015, 05:17:12 PM »
Yes. Scenes created with FP 4.4 should work fine with FP 4.3.7.

Just to be sure: have you updated FShader3.dll in the render nodes or only in the workstation ?
I also suggest to restart the render nodes after copying the dll, to be sure Mental Ray is taking the updated one.
Carlos Quintero
iToo Software

LL4733

  • Newbie
  • *
  • Posts: 14
Re: Network renders slaves crash since last software update
« Reply #6 on: June 27, 2015, 05:20:54 PM »
I only replaced the dll on the slave, not on the workstation. And I didn"t reboot either. I will test these things first.
Thanks.

LL4733

  • Newbie
  • *
  • Posts: 14
Re: Network renders slaves crash since last software update
« Reply #7 on: June 27, 2015, 07:18:09 PM »
Changed the dll in the workstation and de slave, rebooted both, slave still crashes...:-(

LL4733

  • Newbie
  • *
  • Posts: 14
Re: Network renders slaves crash since last software update
« Reply #8 on: June 27, 2015, 07:50:11 PM »
With the new dll, the workstation also crashes when receiving a network render. Reloaded the old dll and the workstation renders the network-jobs again.



iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3319
    • iToo Software
Re: Network renders slaves crash since last software update
« Reply #9 on: June 28, 2015, 08:30:52 PM »
Please, try the attached shader and tell me if there is some difference.
Thanks,
Carlos Quintero
iToo Software

LL4733

  • Newbie
  • *
  • Posts: 14
Re: Network renders slaves crash since last software update
« Reply #10 on: June 29, 2015, 09:42:15 AM »
Thanks for the file, but sorry, no difference.
Ik think we have no other option than to go back to the previous version. (deadlines to meet)
Is it possible to run 4.3.7 on max 2015 besides 4.4.0 on max 2016? (to keep on testing)

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3319
    • iToo Software
Re: Network renders slaves crash since last software update
« Reply #11 on: June 29, 2015, 02:03:20 PM »
Sorry the latest patch didn't work either. It's basically a copy of the shader for FP 4.3.7, reverting the changes introduced in 4.4.0.

In any case, yes. It's possible to have both Forest installed:

1) Instal FP 4.3.7 for 2015.
2) Make a copy of ForestPackPro.dlo from the "plugins" folder, and FShader3.dll from its location.
3) Install FP 4.4.0 (for all Max versions).
4) Overwrite the files of step 2 with the copies.

Carlos Quintero
iToo Software

LL4733

  • Newbie
  • *
  • Posts: 14
Re: Network renders slaves crash since last software update
« Reply #12 on: June 29, 2015, 03:14:24 PM »
Thanks.
We had already re-installed 4.3.7 and 4.4.0 prior to your post, and it worked.
This is how we did:
1. uninstalled FP and reboot.
2. installed 4.3.7 for all max versions (2016 is not included)
3. installed 4.4.0 for 2016. (uncheked the other versions in the installation dialogue box)
Seem to work.
Network rendering in 2015 is up and running again.
Not an ideal situation, but for now we can continue with our jobs :-)

LL4733

  • Newbie
  • *
  • Posts: 14
Re: Network renders slaves crash since last software update
« Reply #13 on: June 29, 2015, 11:46:07 PM »
My collegue did some more tests with 3dsmax 2016 and the render slaves, and from time to time a machine crashes, but succeeds in rendering the job in a second or third attempt. No logic in that.

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3319
    • iToo Software
Re: Network renders slaves crash since last software update
« Reply #14 on: July 02, 2015, 01:48:44 PM »
I've created a new thread, to unify all cases related with Mental Ray and FP 4.4.0. Please, follow the thread here.
« Last Edit: July 02, 2015, 06:14:57 PM by iToo »
Carlos Quintero
iToo Software