Itoo Software Forum

Author Topic: no shadows using vray  (Read 14452 times)

UF7753

  • Newbie
  • *
  • Posts: 24
no shadows using vray
« on: October 30, 2008, 04:59:30 PM »
does forest have any problems working with vray? i'm not having any luck with shadow casting using vray render engine.
« Last Edit: October 30, 2008, 05:27:38 PM by UF7753 »

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3316
    • iToo Software
Re: no shadows using vray
« Reply #1 on: October 31, 2008, 09:31:49 AM »
Hi,

Try disabling the option "Hide planes in viewport" on the "Shadows" rollout. If it doesn't work, please post here a test scene to check it.
Carlos Quintero
iToo Software

UF7753

  • Newbie
  • *
  • Posts: 24
Re: no shadows using vray
« Reply #2 on: October 31, 2008, 04:55:03 PM »
sorry my mistake. i haven't used forest in the last few months and i've been getting into vray along with other things. so when i started back using forest, i was using forest 2. this was mainly because i was having difficulty applying materials to forest 3 initially, but now that i gave it a break i don't seem to have any issues with this (some sort of mental block). i tried some trees using forest 3 in vray and no problems casting shadows. i didn't even have to decheck "hide planes in viewport" to get them.    :-[

UF7753

  • Newbie
  • *
  • Posts: 24
Re: no shadows using vray
« Reply #3 on: February 20, 2009, 11:12:15 AM »
i just noticed that when casting shadows using VRay it does a raytrace of the tree. so when the trees are at right angles to the light source the shadow is a thin line, not a full shadow when using the xShadow on a normal light. i see the new update has support for VRay. is this still going to be an issue?

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3316
    • iToo Software
Re: no shadows using vray
« Reply #4 on: February 20, 2009, 11:28:58 AM »

Are you using Forest Material ? Only materials that use it are capable to cast raytrace shadows properly. If you like, upload a test scene and i will check it.

Forest 3.2 will include other goodies for VRay, as Self-shadowing detection.

Carlos Quintero
iToo Software

UF7753

  • Newbie
  • *
  • Posts: 24
Re: no shadows using vray
« Reply #5 on: February 20, 2009, 12:07:58 PM »
yes, i am using a forest 3 material. it does cast correct shadows when i use a standard light using the xshadow. but i need to use a VRay light, because i have opacity maps and transparency on some objects.

i don't have the file with me right now, but i can attach it later if you still want to see it?

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3316
    • iToo Software
Re: no shadows using vray
« Reply #6 on: February 20, 2009, 02:13:13 PM »
May be the problem is that light is not defined in Forest->Shadows->Raytrace Light.

I've uploaded a test scene using VRay Sun, you can use it as guide (max 2009).

Carlos Quintero
iToo Software

UF7753

  • Newbie
  • *
  • Posts: 24
Re: no shadows using vray
« Reply #7 on: February 21, 2009, 01:15:10 AM »
i used a VRay sun, assigned in the forest shadow as a raytrace light it does render shadows. but i have to de-check 'hide planes in viewport' to cast the shadow.


i couldn't open the .max file you attached. it just stated could not open file with no other reason. i am using MAX9 32bit. probably not important now. i'd be interested to see what the new update will bring for VRay.

EDIT: i have noticed that when the 'hide planes in viewport' is de-checked they appear in the render. i noticed it when i have the self illumination of the material set <100. the viewport planes appeared darker as the self illumination is set lower. when i have the self illumination set to 100 the do not appear at all. i did a test and over laid them in photoshop. maybe i'm missing something - i badly need to read the help file again.
« Last Edit: February 21, 2009, 01:37:32 AM by UF7753 »

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3316
    • iToo Software
Re: no shadows using vray
« Reply #8 on: February 21, 2009, 10:56:10 AM »
Yes, "hide planes..." must be disabled to cast the shadow in VRay (this is fixed in 3.2b).

You cannot open the scene because is for Max 2009, i've upload it a version for Max 9 with this post.

The problem with illumination is that each render engine operates in a different way. Self-illum works with Scanline, but is inverted in Mental Ray / VRay (100% looks as black). We must test the plugin with each possible combination and adapt it. Until now, we have introduced many changes for Mental Ray in 3.1, and now we are working with VRay for Forest 3.2.

Some tricks for Forest 3.1 + VRay (used in this sample scene):

- Instead using Self-illum, use Diffuse Map->Output->RGB Level (i use 3.0)
- To avoid the Self-shadowing issue, de-check "Receive Shadows" in the Forest object (right menu->Properties)

All these problems must be fixed in 3.2, but this is a endless work since each version of Max/Mental Ray/VRay/(put here you favorite render engine)... introduces new changes. My wish is that users post here their problems with Forest, because is the only way to suggest a workaround and fix it for the next release.

« Last Edit: February 21, 2009, 11:01:33 AM by Itoo »
Carlos Quintero
iToo Software

UF7753

  • Newbie
  • *
  • Posts: 24
Re: no shadows using vray
« Reply #9 on: February 21, 2009, 03:37:28 PM »
thanks for the tips. i have the scene much better now. i can imagine the difficulties with the code. this is my 3rd render engine to learn and it's not simple as a user, so for programming it must be worse. anyway, looking forward to 3.2 release.