Itoo Software Forum

Author Topic: Preset Maps and Distribution Maps Not Loading  (Read 152 times)

MU3245

  • Newbie
  • *
  • Posts: 13
Preset Maps and Distribution Maps Not Loading
« on: August 23, 2018, 04:26:13 PM »
I am having real problems with FP. I have a scene and I used a FP preset layered lawn and some gravel. I have repeatedly added the path to the maps for this stuff in the "Config User Paths". The next time I open the scene all that stuff is gone and I have to re-load all the paths into the "Config User Paths". I get error message of missing paths and etc on open.

I save the .mxp file before closing. all the FP paths are there as they should be. After I open the scene again, I open the .mxp in a text editor and all the paths are shown, BUT, Max is not recognizing them. If I then save the .mxp file from max and open it again in text editor All the FP paths (and any other paths that have I have added and are below the FP paths in the list) are gone.

This is killing my workflow right now. Please help

This is killing my productivity

MU3245

  • Newbie
  • *
  • Posts: 13
Re: Preset Maps and Distribution Maps Not Loading
« Reply #1 on: August 24, 2018, 02:04:09 AM »
this problem causes the preset FP stuff to get all messed up when I load the scene. Even after I go thru the process of adding all the paths to the customize user path.

I'm using the most current FP, Max 2019 and Vray next with Win 10. Been using FP without this problem for many years. Please help.

Rokas

  • iToo Software
  • Hero Member
  • *****
  • Posts: 1088
    • iToo
Re: Preset Maps and Distribution Maps Not Loading
« Reply #2 on: August 24, 2018, 09:20:21 AM »
First let me mention, that when installing our plug-in, please double check you are not running any 3ds max or related (like the VRay Spawner) service during the installation process. Sometimes, even closed, 3ds max might not shut down correctly and its processes are still running in the background. To check this you can go to the Task Manager by pressing Ctrl+Shift+Esc and make sure they've both have shut down correctly.

It looks like, that for some reason paths to Forest Pack's assets are missing / not properly mapped under your 3ds Max's configuration accessible by Customize - Configure User Paths - External files and stored in the 3dsmax.ini. The .ini file is located by default here:

%localappdata%\Autodesk\3dsmax\2019 - 64bit\enu\3dsmax.ini

Actually, it's not necessary to configure these paths manually. When Forest is loaded, it's checking if these paths exist and if not, all of them could be added automatically.
If you marked previously the Do not show this message again check-box to disable that pop-up window, you can revert it to its default value (to pop-up) by setting the checkTexturePaths = 1 in the forestpack.ini configuration file located by default at:
%localAppData%\Autodesk\3dsMax\2019 - 64bit\ENU\en-US\plugcfg\forestpack.ini



Hope that helps and please let us know that's all working fine or you are still facing troubles with it.
Rokas
iToo Software

MU3245

  • Newbie
  • *
  • Posts: 13
Re: Preset Maps and Distribution Maps Not Loading
« Reply #3 on: August 24, 2018, 03:36:56 PM »
I changed the "checkTexturePaths" from 2 back to 1 and that fixed all the trouble! I guess I had checked the "do not show again" box at some point.  (why even have that pop up available if checking do not show again causes so much trouble?)

Thanks!!