Itoo Software Forum

Author Topic: Problem with edge mode  (Read 961 times)

RF2189

  • Newbie
  • *
  • Posts: 4
Problem with edge mode
« on: March 08, 2015, 10:56:11 PM »
Hi, this is my first post\project with forest pack pro.
I used falloff curve for density and scale parameters for both grass and gravel. In addition i've got the wihte block geometry set to exclude for both gravel and grass with the edge mode option on. As you can see the grass will go inside the geometry. what's worng? i have a small clamp of grass added as geometry in an other forest obj for the scattering ( like in your grass tutorial ) the gravel is one of the forest amazing presents. The models of the grass are simple geomtry.

thanks...Alessandro

Michal Karmazín

  • iToo Software
  • Hero Member
  • *****
  • Posts: 1545
Re: Problem with edge mode
« Reply #1 on: March 09, 2015, 11:04:30 AM »
Hi,

First, I would suggest you to check used Transform - Translation values. As these transformations are applied after final distribution calculation, in some situations it might produce that kind of troubles. We'll try to fix that behaviour in future releases. Meanwhile we strongly advice to use low values or ideally disable it when facing that kind of issues.

Also, Exclude Object areas are not so exact as splines - a bitmap is used by the distribution algorithm. There is a Resolution parametr (in pixels) that can be adjusted for greater accuracy, if needed. The default value is set to 512px - feel free to set higher values as 1024, 2048 px ...

Kind regards,

RF2189

  • Newbie
  • *
  • Posts: 4
Re: Problem with edge mode
« Reply #2 on: March 09, 2015, 10:40:14 PM »
Hi Michal,
I've try what you suggest me.

With a resolution of 4096 it's almost perfect and the render time do not change. What's change? the memory usage?

I also try removing the translation and now with a resoluzion of 4096 is really better, only some blades pass throw the mesh. I notice that is better if I increase the density and the treshold too. Is it true? Probably i've got a too high value in the translation roll out....I'm experimenting with the parameters :).

If i go above to 6000 px resolution it seam to go crazy and put the grass everywhere  ;)

I've tried also with a spline. And i think that for a so simple geomtrey is the best way to go. Almost no blade inside the woodtile

Thanks for the quick and precise reply.

Alessandro

RF2189

  • Newbie
  • *
  • Posts: 4
Re: Problem with edge mode
« Reply #3 on: March 09, 2015, 10:41:13 PM »
The last 2 test ;)