Itoo Software Forum

Author Topic: Problem with Libraries  (Read 4539 times)

DIMITRIS

  • Full Member
  • ***
  • Posts: 102
Problem with Libraries
« on: August 03, 2011, 03:07:01 PM »
It is really nice to have a new final release... ForestPack is getting better all the time and it is one of my most important tools.

As I have said many times, I am a maxwell user and I was really happy to see that we have a choise to import the billboards not as forest material.... However, this doesn't work...

I can create a library, then I go to create item, I choose billboard... then I choose a .mat file, and the material I want to add... this works fine, I now have a maxwell material there.

If I choose "Import billboards" and use the previous .mat file, although I uncheck the option "Create as forest materials" all I get is forest materials... It seems this checkbox doesn't work.

Also, I would like to add a wish... is it possible to use .max files too, when choosing the library file? Max's material editor can accept both types... I sometimes want to use materials from old projects.

Some info.... Win7 64bit, Max Design 2012 64bit, Maxwell 2.51
« Last Edit: August 03, 2011, 03:09:26 PM by DIMITRIS »
I will sign it only if it is a piece of art!

yuv

  • iToo Software
  • Sr. Member
  • *****
  • Posts: 312
  • iToo Software - CEO
    • Itoo Software
Re: Problem with Libraries
« Reply #1 on: August 03, 2011, 05:53:19 PM »
We will investigate this problem with maxwell, in the last version there is a lot of changes for mesh supports and we are moving some parts to maxscript for easier automation and broader libraries support. But i agree with you that left some things to improve, most with the importers for billboards and meshes and a easier library creation.

Meanwhile i recommend you that if the importer don't create a suitable library for Maxwell, is easy just to edit the resulting library later. Just open the properties for each item and select the corrected .mat library and materials for it. If there is so many elements to change, as the library itself now is a simple XML file, it that can be edited with notepad or any text editor. A good trick it is to do a "search and replace" in the whole file to do bulk changes that can't be done easily with the browser.

At this moment is not possible to use a .max for materials due API limitations to open material libraries, in any case i will investigate futhermore this topic.
Daniel Quintero
Itoo Software
www.itoosoft.com
daniel@itoosoft.com

DIMITRIS

  • Full Member
  • ***
  • Posts: 102
Re: Problem with Libraries
« Reply #2 on: August 03, 2011, 08:38:47 PM »
Thank you very much, I will re-open the library and see what can be done...
I will sign it only if it is a piece of art!

DIMITRIS

  • Full Member
  • ***
  • Posts: 102
Re: Problem with Libraries
« Reply #3 on: August 04, 2011, 11:19:31 AM »
Is it possible that only the checkbox is not working? I mean  if the code for not using forest material exists, maybe you just have to check if the checkbox makes any difference... everything else works ok!
I will sign it only if it is a piece of art!

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3319
    • iToo Software
Re: Problem with Libraries
« Reply #4 on: August 04, 2011, 07:50:11 PM »

You are right, the checkbox was not effect. I just found and fixed the problem.

I have sent you a custom patch by e-mail. Please, tell me if it works.

Carlos Quintero
iToo Software

DIMITRIS

  • Full Member
  • ***
  • Posts: 102
Re: Problem with Libraries
« Reply #5 on: August 04, 2011, 09:04:30 PM »
Really much obliged, I will test asap!
I will sign it only if it is a piece of art!

DIMITRIS

  • Full Member
  • ***
  • Posts: 102
Re: Problem with Libraries
« Reply #6 on: August 04, 2011, 09:23:27 PM »
Well, is it for 2012? ( I read 2011 at the zip's title.)
I get these errors... Sorry but a part of the description is in greek but I guess you'll understand
« Last Edit: August 04, 2011, 09:59:56 PM by DIMITRIS »
I will sign it only if it is a piece of art!

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3319
    • iToo Software
Re: Problem with Libraries
« Reply #7 on: August 05, 2011, 07:37:12 AM »

Sorry, my fault ! I though you was using Max 2011.

I just sent you an updated file.

Carlos Quintero
iToo Software

DIMITRIS

  • Full Member
  • ***
  • Posts: 102
Re: Problem with Libraries
« Reply #8 on: August 05, 2011, 07:52:32 AM »
Great, thanks  :D
I will sign it only if it is a piece of art!

DIMITRIS

  • Full Member
  • ***
  • Posts: 102
Re: Problem with Libraries
« Reply #9 on: August 05, 2011, 08:35:36 AM »
OK, there is something really strange going on!!!

First, the library now works really great, thanks, I can easily add maxwell materials and billboards to my scenes...

What happens now, is that Max freezes, the minute I choose to add a forest object.
What I discovered is that when I deactivate my antivirus, Panda Global Protection 2011, I have no problems... This is the first time I have problems with FPpro and Panda...
Has anyone ever mentioned something similar before?

It looks like if I disable Panda, start MAX and use forest and then re-enable Panda, it works...

*** A question... when and how can I change the default size of the imported billboards?
I mean, I want to create a library of flowers and they get imported as 2.0mX3.0m !!!
How can I change that?
« Last Edit: August 05, 2011, 08:44:14 AM by DIMITRIS »
I will sign it only if it is a piece of art!

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3319
    • iToo Software
Re: Problem with Libraries
« Reply #10 on: August 05, 2011, 05:21:31 PM »

Once imported, you can assign the right size editing each item in the library (select->right click->properties->dimensions). Also remember that you must turn on "Get Size from Library" on the Geometry rollout, before selecting the items.

The problem with Panda is exclusive of the custom patch, or does it happen with Forest 3.6 as well ?

Carlos Quintero
iToo Software

DIMITRIS

  • Full Member
  • ***
  • Posts: 102
Re: Problem with Libraries
« Reply #11 on: August 05, 2011, 05:38:19 PM »
I had no problem before... only with this new patch...
After many tests, I can confirm that if I don't close Panda, I can't work with ForestPack ....
Also, I can't open scenes that contain Forest objects... I tried with scenes created 3-4 days ago so it is 3.6

I was hoping to have a way to define a size for batch import process...
I guess this has to be added to the wishlist...
Since I make a library of flowers, I can have a common size, i.e. 50X50cm and then use the transformation checkbox to show misc sizes...

I will sign it only if it is a piece of art!

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3319
    • iToo Software
Re: Problem with Libraries
« Reply #12 on: August 05, 2011, 06:49:56 PM »

The main difference of the custom patch with 3.6 is that is compiled in the workstation, instead in the build machine that we use for the releases. I don't know how this may affect to Panda, but well... i will prepare a release build for you.

About the library, you can modify easily the sizes editing the xml:

1) Select the library->right click->Open in shell
2) Edit the index.xml file with a text editor
3) Replace on the full text: "<width>2.000000</width> <height>3.000000</height>" with the same string, but updating the sizes

Carlos Quintero
iToo Software

DIMITRIS

  • Full Member
  • ***
  • Posts: 102
Re: Problem with Libraries
« Reply #13 on: August 05, 2011, 06:52:51 PM »
A really nice tip for the library! thanks!

I just hope you find a solution for the other matter too... it is really strange...
I will sign it only if it is a piece of art!

DIMITRIS

  • Full Member
  • ***
  • Posts: 102
Re: Problem with Libraries
« Reply #14 on: August 12, 2011, 03:50:26 PM »
For those who might have similar poblems, I want to say that the only solution that worked was the removal of 3dsmax.exe from the list of programs in Panda firewall.
It is a really strange thing, how a plugin can be a problem for Panda...
The obvious thing would be to send forestpack.dlo to Panda for further investigation and it was not my job to do it... So, I did what I thought as the simplest solution....
It works now...

There have been some mails between me and Carlos and I want to thank him in publick for his immediate response and support.
I will sign it only if it is a piece of art!