Itoo Software Forum

Author Topic: Problem with using Forest Pro for lawn  (Read 7641 times)

QM3423

  • Newbie
  • *
  • Posts: 35
Problem with using Forest Pro for lawn
« on: April 12, 2012, 09:02:05 PM »
I am using a ForestPro clump of grass that is then scattered around another surface to create my lawn areas.  The problem is that the nested clump of grass is a round circle and you can see the 'roundness' of it at the edges of the surface.  Do you have any ideas on how to get more of a straight line along the stone path?  If I use density falloff, then the grass stops short of the walkway.  If I do not use density fall-off then you can see the grass overlap the stone.



jonavark

  • Jr. Member
  • **
  • Posts: 60
Re: Problem with using Forest Pro for lawn
« Reply #1 on: April 12, 2012, 09:22:27 PM »
Often I have to do those areas by hand. It might be a great feature if FP would work through the objects and look for smaller custom objects to fill those areas near edges. So.. if you have 5 objects , say from clumps to singles,  each with different widths FP would find the ones that fit in tight areas and use them. Just a thought.

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3151
    • iToo Software
Re: Problem with using Forest Pro for lawn
« Reply #2 on: April 13, 2012, 09:28:07 AM »

I have a couple of ideas to solve this issue, we will work on them.  ;)

By now, there is not a simple solution. You would create a separate area for the edge, selecting a specific spline and smaller objects (using the "Areas->Select models" feature).

Carlos Quintero
iToo Software

jonavark

  • Jr. Member
  • **
  • Posts: 60
Re: Problem with using Forest Pro for lawn
« Reply #3 on: April 15, 2012, 04:38:04 PM »
Does my suggestion make any sense? 

Suppose you have 5 plants of varying width. When FP gets to the borders and is using size as the factor for placement along an edge or spline, it would cycle through the plants finding the first one with an acceptable width to be placed. This could be switched on and off.. ?

been doing cropcircles for the last year! :)


iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3151
    • iToo Software
Re: Problem with using Forest Pro for lawn
« Reply #4 on: April 16, 2012, 08:51:30 AM »

Jonavark, the problem would be using more than one type of plant, for example grass and flowers.

I was thinking on adding a probabilty value based on the distance to the edge. So, would be possible to solve this problem, besides it is a nice generic feature for other uses.

Anyway, we must make some tests to see the result.

Carlos Quintero
iToo Software

jonavark

  • Jr. Member
  • **
  • Posts: 60
Re: Problem with using Forest Pro for lawn
« Reply #5 on: April 16, 2012, 03:40:49 PM »
yes.. the probability value might do the trick. Although I understand how adding new features like this can cause UI nightmares and affect other features... I wish other software companies were as receptive as you guys are.

simmsimaging

  • Full Member
  • ***
  • Posts: 113
Re: Problem with using Forest Pro for lawn
« Reply #6 on: April 17, 2012, 08:07:46 PM »
Just a +1 for a solution to this. Working on a shag rug and having the same problem exactly.


iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3151
    • iToo Software
Re: Problem with using Forest Pro for lawn
« Reply #7 on: April 19, 2012, 02:48:44 PM »
This is a solution using two overlapped Forest objects; one using a large clump of grass for the inner area, and other with a smaller clump for the edge. The objects are seamlessly blended using two Density Falloff curves, normal and inverted.

This scene also would be implemented with a single Forest object using two areas, except that currently is not possible to use separated Falloff curves. We will include some option to solve this limitation in the next patch.

The scene requires Max 2010, Mental Ray.

« Last Edit: April 19, 2012, 02:50:29 PM by iToo »
Carlos Quintero
iToo Software

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3151
    • iToo Software
Re: Problem with using Forest Pro for lawn
« Reply #8 on: May 08, 2012, 07:27:45 PM »

As promised, this is the version for Forest 3.9, using a single Forest object and two areas.

Carlos Quintero
iToo Software

L&H

  • Newbie
  • *
  • Posts: 11
Re: Problem with using Forest Pro for lawn
« Reply #9 on: July 02, 2012, 12:52:00 AM »
Hi I was looking for a solution to this problem too. I implimented your technique and it works well with a spline area.

Unfortunetly I need to apply this technique to a mesh object. Is there a way to do this as it doesn't allow me to use a mesh as a second area?
First post....so go easy if I have missed something obvious. Thanks

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3151
    • iToo Software
Re: Problem with using Forest Pro for lawn
« Reply #10 on: July 02, 2012, 09:43:13 AM »

No, unfortunately is not possible to use the fallof features with a mesh. But you would generate a spline from the mesh's edge. In this way:

- Convert the mesh to Editable Poly.
- Click Selection->Border (icon).
- Select the exterior edge.
- Edit Borders->Create Shape.
- Use the generated spline as a Forest area.
- Assign the mesh to Forest->Surface (to align the items on Z with the surface).
- Be sure to turn off the "Surface Area" in the Areas list (to not use it as a scattering region).

Carlos Quintero
iToo Software

L&H

  • Newbie
  • *
  • Posts: 11
Re: Problem with using Forest Pro for lawn
« Reply #11 on: July 02, 2012, 12:09:01 PM »
Thanks for your reply. Yes I managed to bundle myself throught to the same conclusion last night. I just hope they don't change the boundries of the planting  :)

JG1281

  • Newbie
  • *
  • Posts: 27
Re: Problem with using Forest Pro for lawn
« Reply #12 on: July 29, 2014, 03:06:59 PM »
Carlos, with your method your have saved my day. Thank you very much!
You know, the silly Germans cut the edges of the lawn with the ruler!
Holger, from Berlin of course.

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3151
    • iToo Software
Re: Problem with using Forest Pro for lawn
« Reply #13 on: July 29, 2014, 04:44:35 PM »
Glad to help, although this thread is a bit old. Short time after it, we released a specific tutorial about this issue here.
Carlos Quintero
iToo Software

Rokas

  • Sr. Member
  • ****
  • Posts: 420
Re: Problem with using Forest Pro for lawn
« Reply #14 on: August 04, 2014, 05:04:30 PM »

I have a couple of ideas to solve this issue, we will work on them.  ;)

By now, there is not a simple solution. You would create a separate area for the edge, selecting a specific spline and smaller objects (using the "Areas->Select models" feature).

Any news on this?
It`s a bit tedious to configure grass every time. Too bad prepared Forest cant be saved to custom library.