Itoo Software Forum

Author Topic: real grass not working with the 3.8.1 Update  (Read 3121 times)

paulmonsef

  • Newbie
  • *
  • Posts: 20
real grass not working with the 3.8.1 Update
« on: May 01, 2012, 09:22:22 PM »
For some reason, since i upgraded to the 3.8.1 update I can't distribute the forest_clump to render a lawn. It works on my other PC, with the 3.8.0 update.

I've even tried, from a blank file. (1) importing the clump geometry (2) trying to select a distribution map other than very scattered renders no objects. now if i save that file and open it on a PC with 3.8.0 installed... I can add a forest object and everything works like normal.

is there a new setting in 3.8.1 or something? and is there a way to download the old version that worked for me?

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3319
    • iToo Software
Re: real grass not working with the 3.8.1 Update
« Reply #1 on: May 01, 2012, 10:13:57 PM »

I just test both files here (Mental Ray and VRay), and seems to work fine with 3.8.1.

What Max version do you use ?
Does it happen rendering the tutorial scene as included or modifying it ?

Carlos Quintero
iToo Software

paulmonsef

  • Newbie
  • *
  • Posts: 20
Re: real grass not working with the 3.8.1 Update
« Reply #2 on: May 01, 2012, 10:45:08 PM »
Hi Thanks for the reply. I am using 3ds Max 2012. Both PC's have Sp2 installed.

I can utilize existing scenes I have set up, including the grass tutorial scene. But when i try to setup a new scene, and import the grass objects I can't populate a lawn. And i only seem to have had this problem since i install the 3.8.1 update and the updated library files.

it's very odd, it worked last week!

yuv

  • iToo Software
  • Sr. Member
  • *****
  • Posts: 312
  • iToo Software - CEO
    • Itoo Software
Re: real grass not working with the 3.8.1 Update
« Reply #3 on: May 01, 2012, 11:06:05 PM »
Please, send us a copy of the scene to support@itoosoft.com to investigate it.
Daniel Quintero
Itoo Software
www.itoosoft.com
daniel@itoosoft.com

paulmonsef

  • Newbie
  • *
  • Posts: 20
Re: real grass not working with the 3.8.1 Update
« Reply #4 on: May 02, 2012, 06:17:59 AM »
I emailed one, thanks!

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3319
    • iToo Software
Re: real grass not working with the 3.8.1 Update
« Reply #5 on: May 02, 2012, 08:38:01 PM »

Hi, if you have sent us the email, we have not received it.

Carlos Quintero
iToo Software

paulmonsef

  • Newbie
  • *
  • Posts: 20
Re: real grass not working with the 3.8.1 Update
« Reply #6 on: May 02, 2012, 11:40:20 PM »
Hi Carlos,
I'll forward it again. I sent it late Tuesday night (pacific time).

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3319
    • iToo Software
Re: real grass not working with the 3.8.1 Update
« Reply #7 on: May 03, 2012, 05:09:19 PM »

Ok, i found the problem: the grass object was in "Display->Render->Meshes" mode, but it should be "Automatic". Instead, the clump object must be "Meshes", in order to generate a mesh to be used as Custom Object.

Carlos Quintero
iToo Software

paulmonsef

  • Newbie
  • *
  • Posts: 20
Re: real grass not working with the 3.8.1 Update
« Reply #8 on: May 04, 2012, 03:30:42 PM »
that was it! I don't understand why, but it works. So, in general this setting would be set to automatic? unless there is a nested forest object being used as a custom object?

I think the grass turned out great!! https://fbcdn-sphotos-a.akamaihd.net/hphotos-ak-snc7/s720x720/577210_422785291078559_132111003479324_1518139_1168527833_n.jpg
« Last Edit: May 04, 2012, 03:34:12 PM by paulmonsef »

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3319
    • iToo Software
Re: real grass not working with the 3.8.1 Update
« Reply #9 on: May 04, 2012, 04:06:20 PM »

That's it. In Automatic mode, Forest generates render instances for VRay and Mental Ray (this should be the preferred behaviour). In Meshes mode it creates an unique mesh for the full object, that is required to be used as Custom Object.
Carlos Quintero
iToo Software

BKE

  • Newbie
  • *
  • Posts: 34
Re: real grass not working with the 3.8.1 Update
« Reply #10 on: May 08, 2012, 03:15:20 PM »

That's it. In Automatic mode, Forest generates render instances for VRay and Mental Ray (this should be the preferred behaviour). In Meshes mode it creates an unique mesh for the full object, that is required to be used as Custom Object.


That grass does look great! I have been using the standard HQPlants grass, and, while it looks nice, it does not look as real as yours. Good job!