Itoo Software Forum

Author Topic: Render Farm Problem  (Read 3014 times)

KL2041

  • Newbie
  • *
  • Posts: 7
Render Farm Problem
« on: December 04, 2012, 01:00:57 PM »
Hey

I got a problem while rendering thru our farm.

We installed on each server the pack in rendering mode ...

Any idea ?

yours


iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3152
    • iToo Software
Re: Render Farm Problem
« Reply #1 on: December 04, 2012, 01:46:31 PM »

Unfortunately the Backburner error is too generic, it would be triggered by any cause. Do you get it only when rendering Forest scenes ?

Please, try rendering a simple test scene (for example a teapot scattered on a plane), and tell me the result.

BTW, what render engine do you use ?

Carlos Quintero
iToo Software

KL2041

  • Newbie
  • *
  • Posts: 7
Re: Render Farm Problem
« Reply #2 on: December 04, 2012, 01:58:28 PM »
We only get this error if we use the forest pack ... without it there is no problem ( same project )...

I will try to render just a plane with some trees...

We use 3 DS MAX 2013 x64

KL2041

  • Newbie
  • *
  • Posts: 7
Re: Render Farm Problem
« Reply #3 on: December 04, 2012, 02:07:15 PM »
After render a plane without trees .. no problem
with trees same error

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3152
    • iToo Software
Re: Render Farm Problem
« Reply #4 on: December 04, 2012, 02:36:28 PM »

Ok, in this case would be necessary to make additional tests to isolate the problem:

Are you using the latest Forest version (3.9.5) ?
Do you use Mental Ray or other render engine ?
What is the result rendering a Forest test scene using Scanline ?
How have you installed Forest in the farm, using the setup program or copying the files ?
Would be possible to run a render test interactively in a render node (without Backburner) ?
What Windows version uses the nodes, is the same than workstations ?

Carlos Quintero
iToo Software

KL2041

  • Newbie
  • *
  • Posts: 7
Re: Render Farm Problem
« Reply #5 on: December 04, 2012, 02:48:24 PM »
Yes we are using 3.9.5 ( 64 bit )
Yes we are using Mental Ray
We will test scanline now :-)
We installed it using the setup.
Rendner result without Backburner ( see attachment )
Servers are 2008 R2 Workstation is Win7

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3152
    • iToo Software
Re: Render Farm Problem
« Reply #6 on: December 04, 2012, 05:14:04 PM »
It seems a missing texture issue. I suggest you add the Forest texture paths, besides all maps from libraries (if used), to Customize->Configure User Paths->External Files.

If you cannot run Max on the nodes to modify the configuration, or want to edit config files directly, the Max texture paths are defined here:

C:\Documents and Settings\<username>\Local Settings\Application Data\Autodesk\3dsmax\<max version>\enu\3dsmax.ini   (see the [BitmapDirs] section).

Also, if you are using Bucket Rendering, please see the following post. It describes a known issue of Max 2013 with external shaders, when using DBR:

http://www.itoosoft.com/forum/index.php?topic=1300.0

Carlos Quintero
iToo Software

KL2041

  • Newbie
  • *
  • Posts: 7
Re: Render Farm Problem
« Reply #7 on: December 05, 2012, 06:48:55 AM »
Here is the 3dsmax.ini from a rendering node ( without edit )


[HeightManagerMetric]
CurrentHeight=-1
Heights=1.500000 2.400000 3.000000 3.600000 6.000000
[HeightManagerUS_Standard]
CurrentHeight=-1
Heights=5.000000 8.000000 10.000000 12.000000 20.000000
[HeightManagerCustom]
CurrentHeight=-1
[Material Editor]
3DMapScale_Meters=3.000000
3DMapScale_Inches=100.000000
DefaultTextureSize_Meters=1.000000
DefaultTextureSize_Inches=48.000000
AmbientColor=0.000000 0.000000 0.000000
[Directories]
ProjectFolder=C:\Users\Administrator\Documents\3dsMaxDesign
Fonts=C:\Program Files\Autodesk\3ds Max Design 2013\fonts
Scenes=.\scenes
Import=.\import
Export=.\export
Help=C:\Program Files\Autodesk\3ds Max Design 2013\help
Expressions=.\express
Previews=.\previews
Images=.\sceneassets\images
Sounds=.\sceneassets\sounds
PlugCFG=C:\Users\Administrator\AppData\Local\Autodesk\3dsMaxDesign\2013 - 64bit\ENU\en-US\plugcfg
MaxStart=.\scenes
VideoPost=.\vpost
Heidi Drivers=C:\Program Files\Autodesk\3ds Max Design 2013\drivers
AutoBackup=.\autoback
Materials=.\materiallibraries
Scripts=C:\Program Files\Autodesk\3ds Max Design 2013\scripts
Startup Scripts=C:\Program Files\Autodesk\3ds Max Design 2013\scripts\startup
Defaults=C:\Program Files\Autodesk\3ds Max Design 2013\en-US\defaults\DesignVIZ.mentalray
RenderPresets=.\renderpresets
RenderOutput=.\renderoutput
Animations=.\sceneassets\animations
Archives=.\archives
Photometric=.\sceneassets\photometric
RenderAssets=.\sceneassets\renderassets
Additional Scripts=C:\Users\Administrator\AppData\Local\Autodesk\3dsMaxDesign\2013 - 64bit\ENU\scripts
Additional Macros=C:\Users\Administrator\AppData\Local\Autodesk\3dsMaxDesign\2013 - 64bit\ENU\usermacros
Additional Startup Scripts=C:\Users\Administrator\AppData\Local\Autodesk\3dsMaxDesign\2013 - 64bit\ENU\scripts\startup
Temp=C:\Users\Administrator\AppData\Local\Autodesk\3dsMaxDesign\2013 - 64bit\ENU\temp
Additional Icons=C:\Users\Administrator\AppData\Local\Autodesk\3dsMaxDesign\2013 - 64bit\ENU\usericons
MaxData=C:\Users\Administrator\AppData\Local\Autodesk\3dsMaxDesign\2013 - 64bit\ENU\
Downloads=.\downloads
BitmapProxies=.\proxies
Assemblies=C:\Program Files\Autodesk\3ds Max Design 2013\bin\assemblies
Page File=C:\Users\Administrator\AppData\Local\Autodesk\3dsMaxDesign\2013 - 64bit\ENU\temp
Hardware Shaders Cache=C:\Users\Administrator\AppData\Local\Autodesk\3dsMaxDesign\2013 - 64bit\ENU\en-US\plugcfg
PlugCFG_ln=C:\Users\Administrator\AppData\Local\Autodesk\3dsMaxDesign\2013 - 64bit\ENU\plugcfg_ln
InstallPath=C:\Program Files\Autodesk\3ds Max Design 2013\
Standard MAX plug-ins=C:\Program Files\Autodesk\3ds Max Design 2013\stdplugs
[InstalledComponents]
ArchitecturalMaterials=0
AdditionalMaterials=0
[XReferenceDirs]
Dir1=.\scenes
[PhotometricAssetDirs]
Dir10=.\sceneassets\photometric
[AnimationAssetDirs]
Dir10=.\sceneassets\animations
[VideopostDirs]
Dir10=.\vpost
[BatchrenderDirs]
Dir10=.\export
[Sounds]
Dir10=.\sceneassets\sounds
[ExternalLinkDirs]
Dir10=.\import
[PreRenderScriptDirs]
Dir10=C:\Program Files\Autodesk\3ds Max Design 2013\scripts
[PostRenderScriptDirs]
Dir10=C:\Program Files\Autodesk\3ds Max Design 2013\scripts
[PluginSettings]
CanAutoDeferDefaultValue=1
EnableActionItemProxySystem=1
EnableCoreInterfaceProxySystem=1
EnableStartupNotificationReplaySystem=1
[Renderer]
DontShowMissingUVWarning=0
UseEnvironAlpha=0
FilterBackground=0
R25Shadows=0
[Performance]
UnitType=0
UnitScale=1
UnitDispType=0
UnitDispMetricType=2
UnitDispUSType=4
UnitDispUSFraction=6
USDefaultUnit=0
UnitDispCustomName=FL
UnitDispCustomValue=660.000000
UnitDispCustomUnit=1
LightingSystem=0
TransformGizmoRestoreAxis=0
SFMask=1
RealTimePlayback=1
PlayActiveOnly=1
[PlugInKeys]
Enabled=1
[CommandPanel]
Columns=1
RollupBreakThreshold=50
[Modstack]
Visible=0
ModStackHeight=128
ShowAllIcons=0
ShowAllSets=0
[WindowState]
GFXType=Nitrous
GFXRenderer=
GFXDevice=
GFXDirect3DVersion=9.0
GFXDirect3DDevice=Hardware
GFXDirect3DBuild=Release
[CuiConfiguration]
LoadedWorkspace=Workspace1
[RenderPresetsMruFiles]
RenderPresetsMruFile1=C:\Program Files\Autodesk\3ds Max Design 2013\renderpresets\3dsmax.scanline.no.advanced.lighting.draft.rps
RenderPresetsMruFile2=C:\Program Files\Autodesk\3ds Max Design 2013\renderpresets\3dsmax.scanline.no.advanced.lighting.high.rps
RenderPresetsMruFile3=C:\Program Files\Autodesk\3ds Max Design 2013\renderpresets\3dsmax.scanline.radiosity.draft.rps
RenderPresetsMruFile4=C:\Program Files\Autodesk\3ds Max Design 2013\renderpresets\3dsmax.scanline.radiosity.high.rps
RenderPresetsMruFile5=C:\Program Files\Autodesk\3ds Max Design 2013\renderpresets\lighting.analysis.assistant.preset.rps
RenderPresetsMruFile6=C:\Program Files\Autodesk\3ds Max Design 2013\renderpresets\mental.ray.daylighting.high.rps
RenderPresetsMruFile7=C:\Program Files\Autodesk\3ds Max Design 2013\renderpresets\mental.ray.daylighting.rps
RenderPresetsMruFile8=C:\Program Files\Autodesk\3ds Max Design 2013\renderpresets\mental.ray.hidden.line.contours.rps
RenderPresetsMruFile9=C:\Program Files\Autodesk\3ds Max Design 2013\renderpresets\mental.ray.no.gi.rps
RenderPresetsMruFile10=C:\Program Files\Autodesk\3ds Max Design 2013\renderpresets\mental.ray.photometric.lighting.with.gi.rps
[Wave Params]
Size_Meters=25.400000
Size_Inches=1000.000000
Len Min_Meters=1.270000
Len Min_Inches=50.000000
Len Max_Meters=1.270000
Len Max_Inches=50.000000
[Smoke Params]
Size_Meters=1.016000
Size_Inches=40.000000
[Noise Params]
Size_Meters=0.635000
Size_Inches=25.000000
[ViewPanelConfiguration]
ViewpanelInactiveThreshold=300000
MaxCachedViewpanelCount=2
[RenderProgressDialogPosition]
Dimension=897 79 379 244
[DialogResizer_SizeAndPositions]
MXSDebugFloater=336 291 640 485 1
[IBitmapPager]
EnabledByDefault=0
TileSizeAutoMode=1
TileWidth=512
TileHeight=512
AutoModeIdlePercent=0.500000
AutoModeRenderMinPercent=0.100000
AutoModeRenderMaxPercent=0.500000
AutoModeRenderGreedyCutoffPercent=0.250000
[RenderVFBPosition]
Position=240 160
[ObjectSnapSettings]
DisplaySnapMarkers=1
SnapMarkerSize=20
UseAxisConstraints=0
SnapToFrozen=0
DisplayRubberBand=1
SnapPreviewRadius=30
SnapRadius=20
[38095bc3,6822268f]
ObjectSnapPluginState=0 0 0 0 0
[6d803b31,4e9b5819]
ObjectSnapPluginState=0 0 0 0 0 0 0 0 0 0
[62f565d6,110a1f97]
ObjectSnapPluginState=1 0
[24960fd5,343a4913]
ObjectSnapPluginState=0 0
[1f120de7,30bc716f]
ObjectSnapPluginState=0 0
[52256183,106b5fda]
ObjectSnapPluginState=0 0 0 0 0 0
[InstanceMgr]
DisplayMSOMtlPropagationMsg=1
[File Resolution Manager]
DoCaching=1
CachingDuration=1000
[BitmapDirs]
Dir1=C:\Program Files\Autodesk\3ds Max Design 2013\Maps
Dir2=C:\Program Files\Autodesk\3ds Max Design 2013\Maps\glare
Dir3=C:\Program Files\Autodesk\3ds Max Design 2013\Maps\adskMtl
Dir4=C:\Program Files\Autodesk\3ds Max Design 2013\Maps\Noise
Dir5=C:\Program Files\Autodesk\3ds Max Design 2013\Maps\Substance\noises
Dir6=C:\Program Files\Autodesk\3ds Max Design 2013\Maps\Substance\textures
Dir7=C:\Program Files\Autodesk\3ds Max Design 2013\Maps\mental_mill
Dir8=C:\Program Files\Autodesk\3ds Max Design 2013\Maps\fx
Dir9=.\downloads
Dir10=C:\Program Files (x86)\Itoo Software\Forest Pack Pro\distmaps\images
Dir11=c:\program files (x86)\itoo software\forest pack pro\maps\HShadows
Dir12=c:\program files (x86)\itoo software\forest pack pro\maps\Standard
Dir13=c:\program files (x86)\itoo software\forest pack pro\maps\Classic
Dir14=C:\Program Files (x86)\Itoo Software\Forest Pack Pro\lib\3D\HQPlants\Free Models\maps
[RenderOutputDirs]
Dir15=.\renderoutput


iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3152
    • iToo Software
Re: Render Farm Problem
« Reply #8 on: December 05, 2012, 09:09:38 AM »

The 3dsmax.ini includes the default Forest paths, but would be necessary to include paths of additional libraries if you use them (as HQ Plants).

The image of the above post, was rendered using Distributed Bucket Renderer ?
What tree models does it use ?

Carlos Quintero
iToo Software

KL2041

  • Newbie
  • *
  • Posts: 7
Re: Render Farm Problem
« Reply #9 on: December 05, 2012, 09:39:58 AM »
We are not useing any other libraries

The above image is from Distributed Bucket Renderer.

We are using: Maple and fir trees

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3152
    • iToo Software
Re: Render Farm Problem
« Reply #10 on: December 05, 2012, 09:52:25 AM »

Ok. Please, see the post linked in my previous post:

http://www.itoosoft.com/forum/index.php?topic=1300.0

Usually this problem generates an error in the mental ray log, but i'm not sure if it would create additional problems as you describe. In any case, there are known issues with DBR and Max 2013. The thread includes a temporary workaround, while Autodesk fix this problem.

Carlos Quintero
iToo Software

KL2041

  • Newbie
  • *
  • Posts: 7
Re: Render Farm Problem
« Reply #11 on: December 05, 2012, 04:19:53 PM »
After using the thread an changing the following settings ( see Attachement ) it works fine :-)

THX