Itoo Software Forum

Author Topic: rescale world units problem  (Read 3487 times)


  • Full Member
  • ***
  • Posts: 100
rescale world units problem
« on: February 18, 2014, 11:16:39 AM »
Just got some issue when rescaling the scene
converting from mm to cm - so change system units and after use rescale world units tool (utilities tab)
all is ok except custom planted forest items - looks like they still in same old coordinates
is there any workaround? I have a lot of work to replant all those forest objects....


  • Administrator
  • Hero Member
  • *****
  • Posts: 4044
    • iToo Software
Re: rescale world units problem
« Reply #1 on: February 18, 2014, 12:44:07 PM »
You are right, Custom Edit is not properly rescaled. We were not aware of this issue.

Please, use the following script to rescale the selected Forest object. You must set the scale factor in "scaleFactor".
scaleFactor = 0.1
for i = 0 to ($.trees.count()-1) do
   $.trees.setposition i (($.trees.getposition i) * scaleFactor)

We'll fix the problem in the next update.
Carlos Quintero
iToo Software


  • Full Member
  • ***
  • Posts: 100
Re: rescale world units problem
« Reply #2 on: February 18, 2014, 01:02:43 PM »
thank you!!!
that worked pretty well

though I got some error but it worked
-- Argument count error: reftarg create wanted 0, got 3


  • Newbie
  • *
  • Posts: 1
Re: rescale world units problem
« Reply #3 on: July 26, 2016, 10:09:50 AM »
Hi Guys,

In an attempt to not create a new post on an old topic i'm hoping This is what this one is about ;)

So I work in Revit in millimeters. I then bring in the FBX to Max and my display units and system units are mm as well. I double check by adding a biped in the scene that is 1750mm tall. Now every so often I get a scene that when i put in a FP Grass preset it comes in being half the height of my house. I try to change the system units to inches or feet and that changes the height when placed a little but it is still waaay to high. I've rescaled when its asked me if I want to and i've declined and nothing gets it just spot on.

I would just go to my geometry tab and adjust the scale factors of all elements within the preset but the problem there is that I reach my max density level much sooner than if it comes in at the right height. I scale from 100% to around 1% or 0.5% and then drop my distribution to 100 or sometimes 45 and still it is too sparse.

Please help a fella out if you can guys, it would be super appreciated times a million.

E of the D

Michal Karmazín

  • iToo Software
  • Hero Member
  • *****
  • Posts: 1839
Re: rescale world units problem
« Reply #4 on: July 26, 2016, 11:48:43 AM »

When using any "scaled surface(s)" (I would suggest you to always double check values in the Scale Transform Type-in window) Forest will inherit its scale (and that's not always desirable). In these cases, I would suggest you to apply the Reset XForm - Reset Selected utility over that surface to reset its local coordinates & scale to avoid similar issues..

Hope that helps.

Best regards,