Itoo Software Forum

Author Topic: Scatter methods  (Read 429 times)

JM2145

  • Newbie
  • *
  • Posts: 9
Scatter methods
« on: January 09, 2018, 10:57:36 AM »
I have two questions - is it possible to exclude just certain scatter objects from a spline?  i.e. i have long and short grass, can i draw a spline and exlcude the long grass from it?  That's a simplified version of what I need to do - i have about 20 items scatters and want to exclude a few from one area.

Secondly, is it possible to to control where objects are scattered based on the shadows from a light source - for example, I'm making a winter scene, i have normal grass, and grass with frost on, I'd like to place the grass with frost on, only where the sun casts a shadow ...

Michal Karmazín

  • iToo Software
  • Hero Member
  • *****
  • Posts: 1483
Re: Scatter methods
« Reply #1 on: January 09, 2018, 11:37:06 AM »
Hi,

Yes, it's possible to define items which will be distributed within these Areas under Areas > Select models > Pick (when the Select Models option is active, the current area will use only the models ticked in this list).

The "direct support" for shadow casting would be probably very resource demanding and might have a big performance hit on complex scenes, but you can bake a shadow map and use it as a mask of the Distribution Map (for example, being mixed within a Composite map, which gives you a lot of possibilities - you can easily change the Opacity for these maps, the Blending Mode, add Mask(s) ...). You might find the following "using a map as an area" post helpful.

Best regards,
« Last Edit: January 09, 2018, 11:40:05 AM by Michal Karmazín »

JM2145

  • Newbie
  • *
  • Posts: 9
Re: Scatter methods
« Reply #2 on: January 12, 2018, 12:49:27 PM »
The areas doesn't seem to be working properly.

I've got a surface, with 9 models scattered over it.

I've then drawing a small rectangle over the bit I only want to scatter some models.

I've added the rectangle as an area, then gone to pick models and chosen the 6 models I want in that area.

It seems to add those models again, rather than removing the others?

Michal Karmazín

  • iToo Software
  • Hero Member
  • *****
  • Posts: 1483
Re: Scatter methods
« Reply #3 on: January 12, 2018, 01:38:42 PM »
Hi,

Please find attached sample scene showing the recommendable set-up for this scenario. By using two (or as many as needed) "not overlapping" Areas and defining items for each of these will do that trick. Hope that helps.

Best regards,

JM2145

  • Newbie
  • *
  • Posts: 9
Re: Scatter methods
« Reply #4 on: January 12, 2018, 03:42:22 PM »
Thanks, that's what I thought I'd have to do, so basically as soon as you use a spline to specify an area, the 'Surface' becomes useless as an area

JM2145

  • Newbie
  • *
  • Posts: 9
Re: Scatter methods
« Reply #5 on: January 12, 2018, 03:47:07 PM »
Out of interest, how does using an area affect the distribution when compared to using a surface.  With the surface, my distribution was perfect, now that I've switched to the areas/splines method, the distribution has changed drastically, in terms of objects being on top of each other and things being a lot closer together

JM2145

  • Newbie
  • *
  • Posts: 9
Re: Scatter methods
« Reply #6 on: January 12, 2018, 03:56:56 PM »
Just to confirm, it's still not working as expected, it's increasing the number of items in my Forest by about 150k+ items.

So just to recap - I have 9 scatter objects (different grass clumps).  1 surface.

On the landscape I want all 9 scatter objects in 'Area A' and only 6 of the 9 in 'Area B'.

I'm no wondering if it's something to do with the Probabilities.

8 of the 9 scatter objects are set to 50%, only 1 is set to 100%.

I imagine I'll be better off just creating 2 Forests.  I was hoping to avoid that as I want the two to blend together.  It's basically a field, with a fenced off area, inside the fenced off area is shorter grass

Michal Karmazín

  • iToo Software
  • Hero Member
  • *****
  • Posts: 1483
Re: Scatter methods
« Reply #7 on: January 12, 2018, 05:30:32 PM »
Hi,

When using surfaces with other Include areas it is important to turn the Surface off. Using individual Forest objects would be an option too.

In case of any further troubles with it, please feel free to send us your scene to check it here. Thanks in advance.

Best regards,