Itoo Software Forum

Author Topic: sketchup > fbx > link into 3ds - grass on wrong plane  (Read 1608 times)

ES1947

  • Newbie
  • *
  • Posts: 21
sketchup > fbx > link into 3ds - grass on wrong plane
« on: March 13, 2014, 11:55:06 PM »
hi

i do some sketches in sketchup that i export as afbx files. i then link the files into 3ds max for easy updating.

when i try to add eg. itoo grass, the grass is added on the vertical side of the object :-/

when i link revit files into 3ds max, there is no problem.

i guess it's a problem with sketchup / fbx, but can i somehow fix this issue?

thanks
Jorgensen
Denmark

Michal Karmazín

  • iToo Software
  • Hero Member
  • *****
  • Posts: 1547
Re: sketchup > fbx > link into 3ds - grass on wrong plane
« Reply #1 on: March 14, 2014, 09:43:47 AM »
Hi,

the problem most probably will be wrong axis orientation after FBX conversion. Please try to modify Axis Conversion parametr under Units rollout (please see screenshot attached).

Hope this solve your problem. Please let me know if it works for you fine now or it´s something else. Thx in advance.

Kind regards,

ES1947

  • Newbie
  • *
  • Posts: 21
Re: sketchup > fbx > link into 3ds - grass on wrong plane
« Reply #2 on: March 14, 2014, 10:41:58 AM »
Hi Michal

Thanks for your input.

When I export my settings is set as attached.

The model looks fine (turning the right way), but it seems that Forest Pro does not 'read' the orientation correct.

I'm sure I'm doing something wrong :-/


Michal Karmazín

  • iToo Software
  • Hero Member
  • *****
  • Posts: 1547
Re: sketchup > fbx > link into 3ds - grass on wrong plane
« Reply #3 on: March 14, 2014, 05:00:31 PM »
Hi,

It should work the way you are doing it but apparently something goes wrong with object coordinates during the SketchUp export linked to 3D Max.

Please try to use AutoCAD .dwg format export as this can be also linked. Give a try to UV mode in Forest object (see screenshot attached) which in this case could be very useful.

Hope this help you.

ES1947

  • Newbie
  • *
  • Posts: 21
Re: sketchup > fbx > link into 3ds - grass on wrong plane
« Reply #4 on: March 14, 2014, 05:27:19 PM »
hi Michal

I tried change surface mapping to uv - that seems to work somehow. The Forest Pro logo is turning the right way, but the objects area rotated :-/

It works fine if i export / link via dwg - but then I miss the textures :-/

Maybe there is a better fbx exporter for sketchup. I think I use the 'default' one.

Thanks

Michal Karmazín

  • iToo Software
  • Hero Member
  • *****
  • Posts: 1547
Re: sketchup > fbx > link into 3ds - grass on wrong plane
« Reply #5 on: March 14, 2014, 05:56:48 PM »
Hi,

please try to play with Direction settings (see screenshot attached). You can also change the rotation of scattered geometry in Transform - Rotation tab ...

ES1947

  • Newbie
  • *
  • Posts: 21
Re: sketchup > fbx > link into 3ds - grass on wrong plane
« Reply #6 on: March 14, 2014, 07:20:55 PM »
Thanks Michal.

Now it's working. The Direction fixed the problem.

Thanks :-)