Itoo Software Forum

Author Topic: Strange behaviour with error message re display faces  (Read 258 times)

Terri Brown

  • Newbie
  • *
  • Posts: 40
Strange behaviour with error message re display faces
« on: October 11, 2017, 02:37:00 PM »
Hi guys,

I've been noticing inconsistent behaviour with the following error message:
"Some Forest objects were not built correctly in the last render.
See "View Stats" (General rollout) to get additional information about the error:"


I have had this before and when I check stats it's most often that I have exceeded the 'max faces' limit under the Display/Render tab. Usually no problem - i just up the max amount to something like 6 or 7 million faces. In this scene however, not only is the message inconsistent (sometimes FP objects render fine, sometimes not - without me changing any settings), but I keep upping the max value to the point where I'm now on 16M faces for a FP object that is really not that intense. It's like everytime the error message appears, I am 0.2M faces too short (so this time I now need 16.2M faces, even though my FP object hasn't changed - see attached).

Sorry but I'm finding this quite strange.

Am I missing something?

Thanks,
Terri

Michal Karmazín

  • iToo Software
  • Hero Member
  • *****
  • Posts: 1396
Re: Strange behaviour with error message re display faces
« Reply #1 on: October 11, 2017, 03:34:31 PM »
Hi Terri,

First let me mention, that the Collisions feature might cause a significant performance hit on large distributions because of very low efficiency of this method - all items need to be generated and later a huge amount of those might be discarded, which might take time & system resources.

Please feel free to send us your scene and we'll check it here.

Best regards,