Itoo Software Forum

Author Topic: The animation was frozen from 1st frame to 99th frame. Why?  (Read 765 times)

cc8boy

  • Sr. Member
  • ****
  • Posts: 276
  • I'll do my best.Welcome to www.c7design.cn .
    • C7design
The animation was frozen from 1st frame to 99th frame. Why?
« on: March 05, 2015, 03:59:18 PM »
Hi iToosoftware,
I chose "Random from map" in animation mode. I tried to render my image sequence via backburner with 6 render nodes.
But why only the first frame and the last frame of the image sequence were different ? The 1st to 99th frames are all the same. The animation was frozen from 1st frame to 99th frame. Why?
I tried to pick one frame from 1~100th frames render locally in MAX2012 main window several times. They were rendered normally. The animation seamed to update normally. But I tried to render the animation continually and locally. The 1st to 99th frames were all the same. Why ?
(MAX2012 64bit FP 4.3.6 win7 64bit)
I've sent my scene via email to you.

We are working hard in virtual effects in 3DSMAX. Welcome to our website in China.

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3156
    • iToo Software
Re: The animation was frozen from 1st frame to 99th frame. Why?
« Reply #1 on: March 06, 2015, 01:40:33 PM »
Hi, apologies by the delay in replying, we needed some time to found the problem: it seems a bug checking the animation intervals of the custom object.

As workaraund, please try adding extra keyframes in the Track view for the Scale gizmo, as shown in the screenshot. The value for the keyframe may be the same of frame 100.
In this case, i added a keyframe at frame 0. Just to be sure, i suggest to add other at end, for example in frame 0 (in this case with value 100). That should solve the problem.

We'll fix the bug in next updates.
Carlos Quintero
iToo Software

cc8boy

  • Sr. Member
  • ****
  • Posts: 276
  • I'll do my best.Welcome to www.c7design.cn .
    • C7design
Re: The animation was frozen from 1st frame to 99th frame. Why?
« Reply #2 on: March 06, 2015, 08:52:59 PM »
I have another question. If I want to delay the animation 1000 frames, should I just move all the keys of the sample objects 1000 frames ? Or I must add a key for each sample object at the 0 frame?
We are working hard in virtual effects in 3DSMAX. Welcome to our website in China.

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3156
    • iToo Software
Re: The animation was frozen from 1st frame to 99th frame. Why?
« Reply #3 on: March 07, 2015, 09:10:52 AM »
Just add one key at frame 0 and other at frame 1000. In that way, we ensure that Forest will update the samples along all animation range.
In fact, there are not problems adding the last key beyond 1000, the fix should work for all animations between 0 and 1000.
Carlos Quintero
iToo Software

cc8boy

  • Sr. Member
  • ****
  • Posts: 276
  • I'll do my best.Welcome to www.c7design.cn .
    • C7design
Re: The animation was frozen from 1st frame to 99th frame. Why?
« Reply #4 on: March 07, 2015, 11:08:07 AM »
Do you mean I must keep the animation range of the keyframes (from the 1st keyframe to the last keyframe) of the sample objects begin with the 0 Frame ?
Thanks for your reply. I hope you will fix this bug soon.
We are working hard in virtual effects in 3DSMAX. Welcome to our website in China.

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3156
    • iToo Software
Re: The animation was frozen from 1st frame to 99th frame. Why?
« Reply #5 on: March 07, 2015, 02:20:18 PM »
Basically the animation range of the keyframes (in the custom object) must be greater than the Forest animation range.
For example, if your animation goes from 0 to 100, as minimum should be keyframes at 0 and 100. To be sure it works, i suggest to extend the last keyframe a bit more, for example add keyframes at 0 and 200.
Carlos Quintero
iToo Software