Itoo Software Forum

Author Topic: toolbar placement  (Read 1557 times)

JI5496

  • Newbie
  • *
  • Posts: 8
toolbar placement
« on: June 13, 2016, 01:16:04 PM »
Hello,

My forest pack and railclone toolbars keep reseting to the default position (see attachment).
Whenever I reposition them or if I move other toolbars right next to them, on the next startup its back to the default again.
is there a fix? i have reset max's ui including the railclone and forest pack .ini.
nothing helps.

thanks for any advice.


 

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3359
    • iToo Software
Re: toolbar placement
« Reply #1 on: June 13, 2016, 05:01:48 PM »
Hi, you are right. It's not working well when toolbars are not placed in the first row of the UI.
We'll check it, but probably will require some change in the code.

Apologies for any inconvenience.
Carlos Quintero
iToo Software

kcpr raffaEl

  • Newbie
  • *
  • Posts: 5
Re: toolbar placement
« Reply #2 on: December 20, 2016, 06:57:35 PM »
Hi!

Did you manage to sort it out?

It's pretty annoying every time I use 3ds Max, Forest Pack Toolbar destroys my UI setup...
« Last Edit: December 20, 2016, 07:04:01 PM by kcpr raffaEl »

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3359
    • iToo Software
Re: toolbar placement
« Reply #3 on: December 22, 2016, 08:50:47 AM »
No yet, sorry.
We requested a code sample to Autodesk regarding this issue (there is few documentation about toolbars), but didn't get it. We'll try again.
Carlos Quintero
iToo Software

TL1895

  • Sr. Member
  • ****
  • Posts: 309
Re: toolbar placement
« Reply #4 on: December 27, 2016, 05:43:26 PM »
kcpr raffaEl,

Thanks, I am so glad somebody decided to speak up; This is definitely most annoying.

VIZIOEN

  • Newbie
  • *
  • Posts: 31
Re: toolbar placement
« Reply #5 on: August 15, 2017, 12:45:01 PM »
Any progress? Quite annoying having to drag them back to their right place, 5 times a day :)

JTP Vis

  • Full Member
  • ***
  • Posts: 107
Re: toolbar placement
« Reply #6 on: August 15, 2017, 01:52:16 PM »
I had a problem with this some time back and observed that the behavior is different, depending on where the "ribbon" toolbar location is. If the ribbon is located above the other tool bars it tends to make the RC and FP toolbars reset every time, but if you put the ribbon toolbar underneath, they stay in place. If you don't use the ribbon, it might be worth turning it on to find out where it would appear, move it so it sits just above the workspace, then disable it again.

I hope this helps.

Bill

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3359
    • iToo Software
Re: toolbar placement
« Reply #7 on: August 15, 2017, 04:44:03 PM »
Unfortunately we could not solve this issue, due to the lack of documentation.
Basicallly we don't know if we're using the right procedure to register the toolbar, because there is not any sample or reference in the SDK we can use. Our request to Autodesk about this issue, never was solved.

But in Max 2018, they changed how toolbars are handled, and now are driven by the Qt interface. We rewrite our code adapted to that, and it seems to work fine (at least in our tests).
I'm afraid we cannot do much more with previous Max versions.

In any case, remember that you create your own toolbar adding same actions (from the Customize Interface menu). Those should work well, because user's toolbar are slightly different.
Carlos Quintero
iToo Software