Itoo Software Forum

Author Topic: Unknown system exception when using script with new FP  (Read 1814 times)

Ramboll

  • Jr. Member
  • **
  • Posts: 57
Unknown system exception when using script with new FP
« on: July 05, 2012, 11:13:57 AM »
Hi


The new version of Forestpack seems to introduce an “Unknown system exception” error in some of our scripts. Here are the relevant lines from one of our scripts:

ny=forest_pro_3 mode:1
ny.surface=$some_object
ny.camauto=true


ny.trees.create point3_pos width height 1

The error seem to occur on the trees.create line, however I’ve run the trees.create command manually in the listener without error, so there must be some other condition involved, perhaps in the creation/initialization lines above or something more obscure in other parts of my code (although these are the only lines directly related to Forestpack).

We are using FP Pro 3.9.2. This script is used a lot in our production so I hope you can find a solution for us



iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3319
    • iToo Software
Re: Unknown system exception when using script with new FP
« Reply #1 on: July 05, 2012, 04:21:34 PM »

We have found and fixed the bug, but unfortunately i cannot find any easy workaround for v3.9.2 using Maxscript.

Please tell me your Max version, i will send you a custom patch with this problem fixed.

Carlos Quintero
iToo Software

Ramboll

  • Jr. Member
  • **
  • Posts: 57
Re: Unknown system exception when using script with new FP
« Reply #2 on: July 06, 2012, 08:37:30 AM »
We`re using MAX 2012 64-bit.

Do we have to install this patch on all of our workstations and renderfarms to?

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3319
    • iToo Software
Re: Unknown system exception when using script with new FP
« Reply #3 on: July 06, 2012, 09:34:29 AM »

It is not necessary. You can install it only in the workstation that runs the scripts.

Please, check your e-mail. I just send it.

Carlos Quintero
iToo Software