Itoo Software Forum

Author Topic: Upgraded to Pro, keyframing the forest object no longer works.  (Read 664 times)

jw

  • Newbie
  • *
  • Posts: 3
Upgraded to Pro, keyframing the forest object no longer works.
« on: January 22, 2018, 07:52:05 PM »
Hi Guys,

So in a scene I have a few Forest objects which are keyframed to move in the Z axis for a simple reveal (sections of land reveal in specific order). I did this originally in Lite. Since upgrading from Lite to Pro key framing no longer works, and the object always reverts back to the original position. When I delete all keyframes and turn off auto key and then scrub the timeline, it reverts back also.

Can anyone suggest a solution?

Thanks

Michal Karmazín

  • iToo Software
  • Hero Member
  • *****
  • Posts: 1555
Re: Upgraded to Pro, keyframing the forest object no longer works.
« Reply #1 on: January 23, 2018, 04:21:39 PM »
Hi,

The Forest Pack Pro has enhanced surface abilities and some of these "unlocked" features might be involved. In the Pro version, when using the default XY Mode: "... items are scattered using the XY plane of the Forest object (in local coordinates), and then placed on the surface moving each object along its Z axis. This mode is best suitable for smooth terrains and used by default when there is not a surface assigned, using the Area splines as boundaries."

Which mode are you using (Generate / Custom Edit)?
Are you using a Surface Area for the distribution? If so, unchecking the Surface > Link to Surface check-box should help.

Please feel free to send us your scene to check it here. Thanks in advance.

Best regards,

jw

  • Newbie
  • *
  • Posts: 3
Re: Upgraded to Pro, keyframing the forest object no longer works.
« Reply #2 on: January 24, 2018, 11:28:46 AM »
Hi,

Thanks for the reply. Yes, that has sorted it thank you. So would a good workflow be to use Generate mode to scatter and then switch to Custom Edit once happy to use with my keyframes? Obviously you have limited knowlege of the scene but doing this doesn't affect the already generated trees?

Thanks

Michal Karmazín

  • iToo Software
  • Hero Member
  • *****
  • Posts: 1555
Re: Upgraded to Pro, keyframing the forest object no longer works.
« Reply #3 on: January 24, 2018, 11:39:35 AM »
Hi,

You're welcome. Glad to hear, that it helped. Yes, that's a possible workflow (as mentioned in our documentation: "A typical workflow might involve working between the two modes by creating an initial scatter of a large area of plants using Generate mode and then switching to Custom Edit to make final adjustments to individual objects to fine tune the composition").

Also, it's possible to animate object used for the distribution - just take in mind, that in case of need to animate object's controllers, please apply to your Custom Object the XForm modifier and animate this (instead of animating Position/Rotation/Scale controllers of the Custom Object as Forest takes control over this during scattering calculation).

Please feel free to check the "Animating in Forest Pack" tutorial, where you can find detailed explication of available Animation modes. There are multiple possible ways and for example, using the Frame From Map mode might suit your needs.

Best regards,

jw

  • Newbie
  • *
  • Posts: 3
Re: Upgraded to Pro, keyframing the forest object no longer works.
« Reply #4 on: January 26, 2018, 06:15:29 PM »
Hi,

Thanks a lot for the tip I'll be sure to check that out. I'm at the end of a deadline now but will definitely read up on that for the next one!

Thanks