Itoo Software Forum

Author Topic: User Paths Config  (Read 159 times)

VelvetElvis

  • Newbie
  • *
  • Posts: 14
User Paths Config
« on: May 03, 2019, 10:31:29 PM »
When the configure user paths is run in Forest automatically, where does it pull that information from? We are having an issue where it is skipping or missing the distmaps folder and we can't figure out why. We are pointing to assets on a network drive, but we should be pointing to distmaps on the local c:Program Files correct? I thought I read somewhere that you don't want to have your distmaps on network drive location as it can slow things down.

This is the post I am referring to.
https://forum.itoosoft.com/forest-pro-(*)/preset-maps-and-distribution-maps-not-loading/msg22003/#msg22003

Thanks!

Michal Karmazín

  • iToo Software
  • Hero Member
  • *****
  • Posts: 1661
Re: User Paths Config
« Reply #1 on: May 06, 2019, 11:06:01 AM »
Hi,

It's taken from the following system registry key:

Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Itoo Software\Forest Pack Pro\TexturePaths

by default set to:

C:\Program Files\Itoo Software\Forest Pack Pro\distmaps\images

Let me add, that if the plug-in doesn't find the keys in HKLM, it searches the same values on HKCU.

Best regards,

VelvetElvis

  • Newbie
  • *
  • Posts: 14
Re: User Paths Config
« Reply #2 on: May 07, 2019, 11:57:15 PM »
Thanks for the reply. I think we found the issue. The registry key file that the install was reading from to set all of the paths to the network drives was missing that path to the distmaps.