Itoo Software Forum

Author Topic: Very slow rendering with forest grass / dark rendering on some frames  (Read 3721 times)

QH1960

  • Newbie
  • *
  • Posts: 6
Hello,

I have a weird problem with Forest & Vray...
- I'm making an animation with moving objects (precalculating the IRMAP, then rendering).
- I'm using forest for animated trees (vrayproxies) and for grass.
- I have an animation where the camera is still for 20 frames, then begins to move.

Here is the problem :
- When camera is still, rendering of the grass is veeeeery slow (at least 10 times slower than normal). Every bucket without grass renders @ normal speed.
- On some, and only some, frames where camera is still, in addition to being very slow to render, grass is very dark.
I've checked my IRMAP files, i have the ones needed and they seem ok.

Included two images, one took more than on hour and has the dark problem, the other one took 10 minutes and looks file.

Thanks,



iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3320
    • iToo Software
Re: Very slow rendering with forest grass / dark rendering on some frames
« Reply #1 on: September 07, 2012, 01:38:12 PM »
Please, try this:

- Create a separate scene, including only the grass and the essential objects to render the scene (lights, camera and so).
- If it has the same problem, convert the grass to stand-alone proxies using Forest Tools (find it in the Utilities panel) and compare.

In this way, we may check if the problem is caused by Forest or VRay. If it fails only using Forest, please send us the files to reproduce the problem here.

Also would be interesting to render a test without GI, to check if the precalculated IRMAP has some effect.

Carlos Quintero
iToo Software

QH1960

  • Newbie
  • *
  • Posts: 6
Re: Very slow rendering with forest grass / dark rendering on some frames
« Reply #2 on: September 07, 2012, 03:50:58 PM »
Hi,

I couldn't try what you've asked for the moment, because of the lack of time (i would need to precalc 10 IRMAP frames)

BUT doing some other tests i've suceedeed in turning the problem ON/OFF with a single parameter change.
- Rendering the problematic image with my initial settings & precalculated IRMAPs, is slow and dark.
- When i change the "calc. pass interpolation samples" (in the Irradiance Map rollout) from 15 to 10, render is fast and grass looks fine.

Which is crazy because this "calc. pass interpolation samples" parameter is supposed to be used during IrMAP calculation and not during rendering.
So, i think we might have found a VRay bug. What is your opinion ?

Thanks.

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3320
    • iToo Software
Re: Very slow rendering with forest grass / dark rendering on some frames
« Reply #3 on: September 07, 2012, 04:57:50 PM »

Yes, it seems a VRay bug. Forest does not modify the GI process in any way, since it basically creates instances for the VRay render engine.

The only point where it would affect the result of the render is Forest Color / Forest Material (to apply the random tint), but we modify only the color base, not the GI. So the possibility of a bug here is very low.

Carlos Quintero
iToo Software

QH1960

  • Newbie
  • *
  • Posts: 6
Re: Very slow rendering with forest grass / dark rendering on some frames
« Reply #4 on: September 07, 2012, 05:24:46 PM »
Thanks for your answer.
I've contacted Vray support and will keep you in touch when i get an answer.
Have a nice day,