Itoo Software Forum

Author Topic: XRef objects not rendering through Backburner  (Read 155 times)

Ramboll

  • Jr. Member
  • **
  • Posts: 65
XRef objects not rendering through Backburner
« on: October 09, 2020, 09:27:05 AM »
Hi

We have an issue after updating to VRay 5 Hotfix 2 and latest FP 6.3.1
We get these errors on our render farm through BB like Unknown error or the pipeline has ended when we are rendering custom FP objects with XRef geometry. When having the trees in the scene as geometry it works fine, but once we xref them out we are not able to render through BB, local render seems fine either way. Is this a known issue? Dont`t know if it is bacause of the newest VRay or FP. We use 3ds MAX 2019.
The problem with having the trees like geometry in the scene is that the file size passes 2 GB.

Hope you guys can help us

Kind Regards
Bjornar
Ramboll

Rokas

  • iToo Software
  • Hero Member
  • *****
  • Posts: 2790
    • iToo
Re: XRef objects not rendering through Backburner
« Reply #1 on: October 09, 2020, 10:03:09 AM »
Hi

I am sorry to hear about the issues. This is not a known issue.
Could you reproduce it on another scene or is it just this one? If You Could, please send us minimal scene to check it.

I would suggest you follow our Distributed Rendering issues (applicable for network rendering with backburner too) post to identify where the problem might be in your case. Basically, there are two common causes for similar issues: the plug-in is not properly installed on all render nodes, or there are missing textures/proxies.

Feel free to find below some more tips that could help with DR issues:
  • Please double check that you did install on all your render nodes the same release of the ForestPack / RailClone plug-in. When installing our plug-in, please double check you are not running any 3ds Max or related service during the installation process.
  • Check under Asset Tracking window, that you can access all used assets also from all used render nodes.
  • Could be, that on some of your render nodes the path to these assets is missing in the 3ds Max configuration Customize - Configure User Paths - External files stored in 3dsmax.ini. The ini file is located by default here:
    %localappdata%\Autodesk\3dsMax\2019 - 64bit\ENU

Also, generally, we recommend resolving all references used by our plug-in with the Asset Tracker to absolute UNC paths. It's not necessary, but usually, this way you avoid any texture path issues while using distributed rendering.

Please feel free to check the following post "Setting up/configuring client computers" related to this topic.

Let me add, that there is always a possibility to use a very powerful tool which is part of Forest Pack Pro / RailClone Pro called "Forest Tools" / "RailClone Tools". This allows you export your scattered geometry as instances. It can be found it under Utilities panel - More ... - Forest Tools / RailClone Tools. Please check this reference. You have a lot of possibilities what will happen with your instances after conversion to mesh (for example moving all instances to new layer is very useful). This way you´ll be able to use the scene even on computers without our plug-ins installed.

Thanks in advance for any further comments on this issue you can share with us.
Rokas
iToo Software