Itoo Software Forum

Author Topic: HQ Grass - Error loading library  (Read 6688 times)

FK3735

  • Newbie
  • *
  • Posts: 4
HQ Grass - Error loading library
« on: April 04, 2013, 02:48:03 PM »
Hi

Installing HQ Plants 1 and 2 works, but after installing HQ Grass I get an error every time I try to load a grass item:
"Error loading library"
"Can't find max file "...\Forestpro\HQgrass\models-vray\models-vray\vray-models-bedstraw-01.max""

It can't be found because the directory doesn't exist, but that's not where I told it to look when I first installed it. There's one "\models-vray\" not 2.

I fixed this issue by actually making an extra folder to match the path.

But when I installed the latest update to Forest Pack I got the problem again, except this time it looks for 3 "\models-vray\".

I can't keep making directories every time I install an update, so I was wondering if you guys could have a look at what might be wrong?

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3076
    • iToo Software
Re: HQ Grass - Error loading library
« Reply #1 on: April 04, 2013, 04:47:28 PM »

Did you install the HQ Grass files within the folder of Forest Pro ? That would be the problem, because this folder is rewritten by the Forest updates.

Please, try this:

1) Unzip the HQ libraries in any folder, not related with Forest. For example: C:\libs\HQ Grass.
2) Reinstall HQ Catalog. That will reset the paths configuration.
3) Open the catalog, and select the HQ library folder when Forest request it.

Carlos Quintero
iToo Software

FK3735

  • Newbie
  • *
  • Posts: 4
Re: HQ Grass - Error loading library
« Reply #2 on: April 05, 2013, 10:36:03 AM »
Hi

I did install the HQ Catalog program in the iToo Software folder in programfiles, as this was default.

I have now installed it in a separate location, so next update won't remove my settings from HQ Catalog, hopefully.


However, the problem still persists. I have placed all models on a network drive, separate from the installation path of the programs(Easier for everyone at the office to find the files at the same place).
When I choose installation path of HQGrass, I have to choose the folder that's named "models-vray" inside "HQ grass" folder for it to accept. But then I get the problem I tried to describe:

"Error loading library"
"Can't find max file "\\...\HQ grass\models-vray\models-vray\vray-models-bedstraw.max"

Even though I just told it that the models was in "\\...\HQ grass\models-vray\"

The only fix I could make up, was to actually make another "models-vray" folder. But as it stands now, after a few re-installs, I have 4 of these folders.

I think there might be something about the installation of HQ grass, that's not present for HQ plants 1 & 2, because they work perfectly.


The only difference between the catalogs on our network drive, is that HQ Grass is named "HQ grass" and HQ Plants 1 & 2 is named "hq_plants_1". Maybe it doesn't work with normal spaces?

Jose

  • iToo Software
  • Newbie
  • *****
  • Posts: 19
Re: HQ Grass - Error loading library
« Reply #3 on: April 05, 2013, 02:50:06 PM »
Please tell us which version you use of 3ds Max and Forest. And, if it's the Pro version or lite.
We will study the problem.
José Antonio Cordón
Itoo Software
www.itoosoft.com
jcordon@itoosoft.com

FK3735

  • Newbie
  • *
  • Posts: 4
Re: HQ Grass - Error loading library
« Reply #4 on: April 11, 2013, 09:50:31 AM »
Hi

We use ForestPackPro 403(The problem was present on the 402 release too), and 3ds Max 2010

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3076
    • iToo Software
Re: HQ Grass - Error loading library
« Reply #5 on: April 11, 2013, 05:55:10 PM »

I'm trying to reproduce the problem here using Max 2010, but everything work fine. Apparently there is not difference using spaces in the folder name.

The path of the HQ Grass library is stored in the following registry key. You can check it using the "regedit" tool:

[HKEY_CURRENT_USER\Software\Itoo Software\Forest Pack Pro\LibraryMacros]
"hqgrass_path"="E:\lib\HQPlants\hq grass"

Please, try this:

1) Close Max.
2) Download and install the latest version of HQ Catalog.
3) Move the library to its normal storage, removing the extra folders from the path.
4) Using regedit, set the path in the above registry key.
5) Try the library, it should work without problems.
6) Close Max, reinstall Forest and use the library again.

Does Forest ask the path of HQ Grass again ? Does the registry value changes ?

If you want to do the tests locally (without modifying the network library), you can make a copy of HQ Grass in your hard disk and set the path as described above.

Thanks for your collaboration,

« Last Edit: April 11, 2013, 05:57:36 PM by iToo »
Carlos Quintero
iToo Software

PE4615

  • Newbie
  • *
  • Posts: 2
Re: HQ Grass - Error loading library
« Reply #6 on: May 09, 2013, 10:57:44 PM »
I have just posted another place but this might be the right place.
I get a message each time i open a scene with HQ plants saying
Missing External Files.
..\..\..\..\HQ_Plants_\maps\bark_maple.tga

..and other files.

I have looked in the regedit and the mentioned path is not there.
When i open the asset tracking, and look for the path, it is already pointing to the right location?!
Why will it not recognize the path?
Also when I open the HQ plant library in FPP it is all working?
Thanks!

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3076
    • iToo Software
Re: HQ Grass - Error loading library
« Reply #7 on: May 10, 2013, 08:53:44 AM »

The first time HQ Catalog uses a specific library, it adds the texture path to Customize->Configure User Paths->External Files. Perhaps for some reason the path was not added to your configuration.

Please, add the HQ Plants texture paths manually to Max, that should solve the problem. This issue has no relation with the registry and the problem described above.

You would relink the paths manually using the Asset Tracker, but this should not be necessary if User's Paths is well configured.

Carlos Quintero
iToo Software

TL1895

  • Sr. Member
  • ****
  • Posts: 294
Re: HQ Grass - Error loading library
« Reply #8 on: May 29, 2013, 11:37:25 PM »
i have similar problem, but a little different.  If I merge a "vray" model in from HQ1, it comes with a MR material applied.
Secondly, when using HQ Grass via the HQ catalog, I noticed some of the models that forest was Xreffing were the Mental Ray files.
I emailed Mentor about these several times over past year, with no reply so far...

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3076
    • iToo Software
Re: HQ Grass - Error loading library
« Reply #9 on: May 30, 2013, 09:21:53 AM »

Please, be sure you use the latest Forest upgrade, and check that the "Merge" option is selected in the library settings, not "XRef".

About the materials, also there is a selector for that. It must be set in "Automatic" or "Vray" mode.

Carlos Quintero
iToo Software

TL1895

  • Sr. Member
  • ****
  • Posts: 294
Re: HQ Grass - Error loading library
« Reply #10 on: June 03, 2013, 02:12:02 PM »
yes, all my options are correct.  It happens even when just merging in one of the mentioned models.  Try merging one of the HQ plants 1 into a scene and it will be obvious...the max file claiming to be v-ray, actually has mental ray material applied.   to time consuming to open each model, open the material lib each time for V-ray, find the right material, and apply it, then save.

Too much time IMO...

TL1895

  • Sr. Member
  • ****
  • Posts: 294
Re: HQ Grass - Error loading library
« Reply #11 on: June 03, 2013, 02:16:27 PM »
Also, please see my post above.  The problem is not specific to FPP, but to the HQ plants vol1, so I post in the HQ plants section...
Thanks again, and still no word from Mentor.

TL1895

  • Sr. Member
  • ****
  • Posts: 294
Re: HQ Grass - Error loading library
« Reply #12 on: August 09, 2013, 05:59:48 PM »
Hello, any update on this issue?  Still no sign of the promised update from K.K.
Thanks
« Last Edit: August 09, 2013, 06:08:03 PM by TL1895 »

iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3076
    • iToo Software
Re: HQ Grass - Error loading library
« Reply #13 on: August 09, 2013, 06:44:54 PM »
No, sorry. We have not reply from Konstantin either, regarding this issue.
Carlos Quintero
iToo Software

TL1895

  • Sr. Member
  • ****
  • Posts: 294
Re: HQ Grass - Error loading library
« Reply #14 on: August 09, 2013, 06:49:28 PM »
Okay, well, at least I'm not "special" LOL.

Thanks again