Itoo Software Forum

Author Topic: Confusion with material IDs  (Read 2759 times)

titopte

  • Newbie
  • *
  • Posts: 8
Confusion with material IDs
« on: May 22, 2013, 11:15:11 PM »
Hi, i am using Railclone Lite for some electric piping on a ceiling and faced a problem regarding materials.

When I select the first object -the pipe- to be the default segment, the RC object updates, but not carrying the material with the object. That is, it remains showing and rendering the defaul color that the source guide spline had when created.

I then add the boxes for detours at every corner, and some fixations devices evenly. The boxes at every corner has a multimaterial asigned.

I then create a new multimaterial to apply to the RC object hoping that the IDs would be ordered the same way than appearing in the segments list.

But i have no luck matching the IDs  to a reasonable result in the complete object, even getting confusing results with the same id and the same segment several times.

Hope to be clear, but in the end i am asking please to gimme some tip on the workflow to asign proper material to each segment, even when one of them should have a multimaterial.

Thanks in advance
T



iToo

  • Administrator
  • Hero Member
  • *****
  • Posts: 3318
    • iToo Software
Re: Confusion with material IDs
« Reply #1 on: May 23, 2013, 12:07:22 AM »

The material workflow for RailClone is pretty simple: just create a multi-sub material, and use it both for segments and the RC object itself. You also must assign the material to the RC object, it is not assigned automatically.

The IDs are copied directly from the segments, so nothing special with that. Anyway, if you have problems with a specific object, please post it here.

Carlos Quintero
iToo Software

titopte

  • Newbie
  • *
  • Posts: 8
Re: Confusion with material IDs
« Reply #2 on: May 23, 2013, 02:08:53 AM »
ok, thanks. Just found another thread and i think i got it.
There should not be repeated ids in al the polys of all the segment objects used if you want different materials on them.

So the RC object does like attaching the segment objects together, but doesn´t assign new id among them. My wrong was assuming that it does.

Thanks, will try again tomorrow morning
Cheers