Itoo Software Forum

Author Topic: Add segment on start / end of section with specific material ID + marker issues.  (Read 544 times)

DT

  • Jr. Member
  • **
  • Posts: 85
Hi, I'm trying to add a segment to the start and end of a spline section, with a specific material ID. I tried with adding it on vertex corners with a conditional, but this doens't always work, because something RC thinks it still is the previous ID and omits the segment.

I also like to add a segment sometimes on a vertex corner within that specific ID when, it's a 90° or more angle.

I tried this (and the previous problem) with markers on the same spline. But when I use, snap to vertex (to the underlying spline with different IDs) to add it and change the ID of the marker, I run into the following problems:

-Sometimes it's 45° rotated (or some very weird rotation) sometimes not. Even when it is on a corner that just divides a straight line.
-Sometimes if I change the ID of the marker, the segment simply doesn't change to the desired segment.

This can be solved if I move the marker a little bit. So it seems that markers that share the same position (but not even exactly the same position) of a underlying vertex (with or without ID changes from one section to the other), have some weird issues.

Could this be related to being 'far away' from the origin? I tried moving it closer the origin but it doesn't change anything. These are big buildings and I'm drawing in cm.


« Last Edit: November 09, 2021, 11:05:05 AM by VIZIOEN »

Paul Roberts

  • iToo Software
  • Hero Member
  • *****
  • Posts: 2828
Hi,

This would be expected because internally the marker is dividing the spline. If you put it on a spot with an existing corner vertex then you may get issues as it gets "double divided". Do you have a mockup or an image of what you'd like to achieve? It'd help me to create a sample file for you to look at.

Best,
Paul
Paul Roberts
iToo Software

DT

  • Jr. Member
  • **
  • Posts: 85
Hi,

This would be expected because internally the marker is dividing the spline. If you put it on a spot with an existing corner vertex then you may get issues as it gets "double divided". Do you have a mockup or an image of what you'd like to achieve? It'd help me to create a sample file for you to look at.

Best,
Paul

Hi Paul,

You can find the 3ds Max file here: https://we.tl/t-u9ozcgf4EA

I've turned off the other nodes except for the walls and such. And the Border and Vertical Profile Arrays. The problem is with the vertical profile arrays and the first RC spline modifier. As you will see, when you move the RC spline markers a bit, they will look correct, now 50% of them aren't correct more or less.

Thank you.

Paul Roberts

  • iToo Software
  • Hero Member
  • *****
  • Posts: 2828
Hi,

Have you tried the RailClone 5 beta for this style? Initially I struggled to see the issue in your file, but I think it's because I had the beta installed. When I rolled back I could see several errors of the type you describe. There have been several fixes and improvements to markers in RailClone 5 that you may find have helped resolve some of the problems.

If you're able to try it out and let us know if it helps we'd appreciate it.

Best,
Paul
Paul Roberts
iToo Software

DT

  • Jr. Member
  • **
  • Posts: 85
Hi Paul,

Thanks for getting back. Upon upgrading to the beta, the issues were still there. But new issues arrised now. The markers on the second modifier, were all changed to ID 1, easily solved by changing them again to 2 though. But might be a bug.

BUT when I deleted the older markers on the first modifier and added them again. I indeed didn't have any issues anymore, except for one, which was solved by moving it ever so slightly, so the improvements worked.

Although I was hoping for a more parametric solution, instead of having to add the profiles manually with the markers. Isn't there a way of adding segments to the start and end of sections (with a specific ID), as I described in my first post.

Thank you.


Paul Roberts

  • iToo Software
  • Hero Member
  • *****
  • Posts: 2828
Are you able to use the generator's Limit by material ID features? This would give you a start and end section for each material ID on the spline.



Best,
Paul
Paul Roberts
iToo Software

DT

  • Jr. Member
  • **
  • Posts: 85
Are you able to use the generator's Limit by material ID features? This would give you a start and end section for each material ID on the spline.



Best,
Paul

Great, I tried it with a conditional first but that didn't give me the desired results, limiting it with the generator worked like a charm :-). Thanks for the help Paul appreciate it.