Itoo Software Forum

Author Topic: backward compatibility  (Read 1186 times)

GT4505

  • Full Member
  • ***
  • Posts: 120
    • claar.be
backward compatibility
« on: May 24, 2018, 09:53:06 AM »
Hi There,

I've been testing with Vray Next beta's for a while now.
While it's a good update, I'm not yet ready to switch all my licenses to the new version cause I've got to upgrade all my node licenses too.
So I'd like to use the stable build which I have bought my licenses for just a while ago.

In order to work with RC and FRST I had to use your beta's.
If I now switch back to the last stable builds will I still be able to open my RC and FRST objects, which is crucial to me.

Thank you
Pieter van Stee

Rokas

  • iToo Software
  • Hero Member
  • *****
  • Posts: 2520
    • iToo
Re: backward compatibility
« Reply #1 on: May 24, 2018, 10:12:25 AM »
Unfortunately that'll depend on several things like Forest Pack / RailClone features used and so on, but it will cause issues especially FP6->FP5 downgrade.
I'm afraid we can't guarantee full backwards compatibility as many new features were introduced and several bugs fixed. Thanks for your comprehension.
Rokas
iToo Software

GT4505

  • Full Member
  • ***
  • Posts: 120
    • claar.be
Re: backward compatibility
« Reply #2 on: May 24, 2018, 10:55:51 AM »
Hi Rokas,

Thank you for your answer.
Then is it possible to use the last version of RC & FRST I've used with Vray Next Beta (last version)?
Thanks
Pieter van Stee

Rokas

  • iToo Software
  • Hero Member
  • *****
  • Posts: 2520
    • iToo
Re: backward compatibility
« Reply #3 on: May 24, 2018, 11:07:40 AM »
Would You state versions for all 3 products?
Rokas
iToo Software

nmoser

  • Newbie
  • *
  • Posts: 9
Re: backward compatibility
« Reply #4 on: June 18, 2020, 12:33:26 PM »
Will I be able to work on a project done with FP 6.3.0  on a computer with version 6.1.6?
« Last Edit: June 18, 2020, 12:39:07 PM by nmoser »

Rokas

  • iToo Software
  • Hero Member
  • *****
  • Posts: 2520
    • iToo
Re: backward compatibility
« Reply #5 on: June 18, 2020, 12:59:21 PM »
Will I be able to work on a project done with FP 6.3.0  on a computer with version 6.1.6?

Compatibility, depends on several things like the render engine, used Forest Pack / RailClone features and so on, but it possibly might cause issues and we always highly recommend, that all involved computers should use the same release.
I'm afraid we can't guarantee full backwards compatibility nor we have test it.
Thanks for your comprehension. Compatibility should work when updating to newer versions.
Rokas
iToo Software

nmoser

  • Newbie
  • *
  • Posts: 9
Re: backward compatibility
« Reply #6 on: June 18, 2020, 01:21:24 PM »
Thanks.

nmoser

  • Newbie
  • *
  • Posts: 9
Re: backward compatibility
« Reply #7 on: June 18, 2020, 07:43:38 PM »
Is it possible to have two different versions of RC installaed on the same computer for different versions of 3ds MAx

I was able to do this with FP:

1. Installed 3ds Max 2019 and 2021
2. Installed Forest Pack 6.3.0
3. Installed Forest Pack 6.1.6

As a result I now have FP 6.3.0 on max 2021 and FP 6.1.6 on max 2019

I tried to do the same with RC but the installation removed RC on 3ds MAx 2021.
This could be quite handy as I'm dealing with projects have to be kept with the same ver. of RC and FP as a matter of across the team and renderfarm compatibility
« Last Edit: June 18, 2020, 07:47:17 PM by nmoser »

Rokas

  • iToo Software
  • Hero Member
  • *****
  • Posts: 2520
    • iToo
Rokas
iToo Software