Itoo Software Forum

Author Topic: Clipping area moves segments?  (Read 1416 times)

BI1654

  • Newbie
  • *
  • Posts: 38
Clipping area moves segments?
« on: July 11, 2014, 02:12:05 PM »
So trying to create a tiled ceiling. I very simply want to create the entire array, position it correctly, and then clip the unwanted parts.
This works fine up until the clipping part, where it shifts the position of the tiles and I can no longer move them where I want.
There seems to be a limit as to how far i can move them before they snap back to where the were and the cycle starts again.

I just need it to clip the unwanted parts out without changing the position. I cant see any reason why it should move?
Any help appreciated

Paul Roberts

  • iToo Software
  • Hero Member
  • *****
  • Posts: 1517
Re: Clipping area moves segments?
« Reply #1 on: July 11, 2014, 02:47:16 PM »
Hi,

Thanks for contacting us. When using a clipping spline it should not affect the position of the tiles unless you have Extend X/Y size to Area switched on.



To get the ceiling to remain static use the X Y size, position the RailClone object and then add your clipping spline, ensuring that Extend X/Y size to Area is switched off.


If you still see the same problem, if possible it'd be great if you could upload a stripped scene file so that I can take a closer look.

I hope that helps.

Thanks,

Paul
Paul Roberts
iToo Software

BI1654

  • Newbie
  • *
  • Posts: 38
Re: Clipping area moves segments?
« Reply #2 on: July 11, 2014, 02:57:20 PM »
Hi
Im not using "Extend X/Y size to Area"
Im just using 2 splines, and then another spline for clipping.

I'll upload a stripped scene, thanks

BI1654

  • Newbie
  • *
  • Posts: 38
Re: Clipping area moves segments?
« Reply #3 on: July 11, 2014, 03:16:57 PM »
Ok here we go.
So if you move the horizontal line (called "move this one" :)) you can see how the ceiling keeps snapping back to its original position as you move it.
Likewise if you move the clipping area.

I dont know how to record animated gifs, so hope this makes sense when you open it



Paul Roberts

  • iToo Software
  • Hero Member
  • *****
  • Posts: 1517
Re: Clipping area moves segments?
« Reply #4 on: July 11, 2014, 03:55:30 PM »
Hi,

Thanks for the scene, it's very helpful. I can see the problem . It seems the count for the sequence operator on the Y axis is ignoring segments that are outside of the clipped area, so it always starts counting from the first visible tile in the array . This doesn't seem to happen on the X axis. I'm going to send this to our development team, I suspect it might be a bug. I'll get back to you here soon.

Thanks,

Paul
Paul Roberts
iToo Software

BI1654

  • Newbie
  • *
  • Posts: 38
Re: Clipping area moves segments?
« Reply #5 on: July 11, 2014, 04:08:22 PM »
Ok thanks, are there any workarounds in the mean time? (other then instancing and fixing manually)

Paul Roberts

  • iToo Software
  • Hero Member
  • *****
  • Posts: 1517
Re: Clipping area moves segments?
« Reply #6 on: July 14, 2014, 03:43:50 PM »
Hi,

Thanks for bringing this issue to our attention, the bug has been fixed for the next update. In the meantime please find attached a suggested workaround. I've swapped the sequence operator for a Selector connected to an arithmetic node to create the pattern. This means that an offset can be applied to change the starting tile.

I hope that this helps, please let me know if you have further questions.

Thanks,
Paul
Paul Roberts
iToo Software

BI1654

  • Newbie
  • *
  • Posts: 38
Re: Clipping area moves segments?
« Reply #7 on: July 14, 2014, 03:56:04 PM »
Great stuff, thanks. Huge time saver.