Itoo Software Forum

Author Topic: Clipping of Array not working proper  (Read 5176 times)


  • Newbie
  • *
  • Posts: 8
Clipping of Array not working proper
« on: July 04, 2013, 02:44:53 PM »
Hey Guys,

i tried to setup a Array S2 Structure with Railclone where Im forced to clip the ends (LeftSide/RightSide), sadly the clipping isnt working correctly.
The Geometry of the Double T-Girder is destroyed (see attached image / Max2012 file). Is there a way to avoid this error or maybe even a better way for the setup without clipping i over looked?

Thanks for the help,


  • Administrator
  • Hero Member
  • *****
  • Posts: 3974
    • iToo Software
Re: Clipping of Array not working proper
« Reply #1 on: July 04, 2013, 07:00:22 PM »
The RailClone clipping is based on Max booleans, that unfortunately not always work as intended. I'm afraid there is not much we can do about it.

In this case, if you need clipping only to create shorter start/end pieces at the first rows of the array (as far as i can see from your clipping spline), it can be done using a Sequence on Y. Just set the first counter to the number of rows you want to change, and the second counter (for the rest of array) to a high value (as 99).

The shorter left side segment uses a Left padding to get the effect. It's necessary to create a similar piece for the right side (usually using Right padding).

I hope that helps.
Carlos Quintero
iToo Software


  • Newbie
  • *
  • Posts: 8
Re: Clipping of Array not working proper
« Reply #2 on: July 09, 2013, 02:44:33 PM »
Thanks for your fast reply and sorry for my late one.
Sadly i was already thinking thats a max boolean problem, these thing never worked well.
But your suggestion with the sequence on y helps a lot and is way more elegant, but it will need more time to setup cause i have lots of different start and end pieces.

But as said thanks for your help and good support.