Itoo Software Forum

Author Topic: Compose operator issue  (Read 415 times)

mike.kominek

  • Newbie
  • *
  • Posts: 26
Compose operator issue
« on: March 22, 2019, 04:06:35 PM »
Hello again,

One thing that I noticed when using Compose in Grouped mode is that it does not create a new unique piece out of several segments as the description says, instead of adds them in order in a strange way that appears almost as a glitch to me.

It is difficult to explain for me but the first Composed "Grouped "segment only contains one of the two segments, other composed segments contain both and than the last one only contains the second segment. Attaching picture for demonstration.


Rokas

  • iToo Software
  • Hero Member
  • *****
  • Posts: 2515
    • iToo
Re: Compose operator issue
« Reply #1 on: March 25, 2019, 09:31:56 AM »
Hi. Are the pivots aligned to the same origin? If so would You mind attaching Your file so we can inspect it?
Rokas
iToo Software

mike.kominek

  • Newbie
  • *
  • Posts: 26
Re: Compose operator issue
« Reply #2 on: March 25, 2019, 12:23:06 PM »
Hi Rokas,

attaching the scene with an example. As you can see the segments are using automatic Y and X pivots

Thanks for looking into this.




Rokas

  • iToo Software
  • Hero Member
  • *****
  • Posts: 2515
    • iToo
Re: Compose operator issue
« Reply #3 on: March 25, 2019, 01:24:37 PM »
Thanks for file.
Automatic is not correct for such case.
You need to set to Pivot all 3 axis for all 3 objects:


And Adjust physical pivot to the same World space:


After doing this. It will be as You intended. Hope this helps.
Rokas
iToo Software

mike.kominek

  • Newbie
  • *
  • Posts: 26
Re: Compose operator issue
« Reply #4 on: March 25, 2019, 02:08:00 PM »
Thanks Rokas

mike.kominek

  • Newbie
  • *
  • Posts: 26
Re: Compose operator issue
« Reply #5 on: March 27, 2019, 04:43:28 PM »
Another issue I have with Compose is that when I want to apply padding to a composed segment, the padding is still applied to all individual segments that are now supposed to be one big unique piece.

Compose in general gives me a lot of grief. I presumed its supposed to be sort of a glue of segments that are parametric before composing, but parameters applied after composing should apply to the whole new composed piece. not the individual segments its made of. This removes a massive chunk of flexibility from RC. Is it intentional?

Thank you